Am 17. April 2018 01:27:11 MESZ schrieb Paul-Andre Panon 
<paul-andre.pa...@avigilon.com>:
>Hi,
>
>When trying to apply python 2.7 package updates on our Ubuntu 16.04
>systems, Spacewalk tries to commit suicide by removing all the
>Spacewalk packages and multiple python packages (as well as sssd if
>it's in use). To fix the problem we need to back up the Spacewalk
>sources.list and Spacewalk repo files, switch back to Ubuntu repos by
>swapping to pre-Spacewalk sources.list, re-install python2.7 and the
>Spacewalk client, and the switch to the Spacewalk sources.list and repo
>file again.
>
>We've had problems with the Multi-Arch header in Packages before.
>However I've checked but the Multi-Arch: header for python2.7 packages
>is still set up correctly in the main, update, and security channel
>Packages files since I fixed them the last time, so that doesn't appear
>to be the problem. Does anybody have any idea what might be going on?
>
>root@u16server:/home/local/YORK/ppanon# sudo rhn_check -vvv
>D: check_action{'action': "<?xml
>version='1.0'?>\n<methodCall>\n<methodName>packages.update</methodName>\n<params>\n<param>\n<value><array><data>\n<value><array><data>\n<value><string>libpython-stdlib</string></value>\n<value><string>2.7.12</string></value>\n<value><string>1~16.04</string></value>\n<value><string></string></value>\n<value><string>amd64-deb</string></value>\n</data></array></value>\n<value><array><data>\n<value><string>python</string></value>\n<value><string>2.7.12</string></value>\n<value><string>1~16.04</string></value>\n<value><string></string></value>\n<value><string>amd64-deb</string></value>\n</data></array></value>\n<value><array><data>\n<value><string>python-minimal</string></value>\n<value><string>2.7.12</string></value>\n<value><string>1~16.04</string></value>\n<value><string></string></value>\n<value><string>amd64-deb</string></value>\n</data></array></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n",
>'version': 2, 'id': 1968}
>updateLoginInfo() login info
>D: login(forceUpdate=True) invoked
>logging into up2date server
>D: rpcServer: Calling XMLRPC up2date.login
>D: writeCachedLogin() invoked
>D: Wrote pickled loginInfo at 1523920847.76 with expiration of
>1523924447.76 seconds.
>successfully retrieved authentication token from up2date server
>D: logininfo:{'X-RHN-Server-Id': 1000010078, 'X-RHN-Auth-Server-Time':
>'1523920847.75', 'X-RHN-Auth':
>'Y1ME414TmOz4KzZw2TldrrD/57wOcaVxdYol4N4YRSY=', 'X-RHN-Auth-Channels':
>[['xenial', '20180408040248', '1', '1'], ['xenial-security',
>'20180408040949', '0', '1'], ['xenial-security-universe',
>'20180408040914', '0', '1'], ['xenial-updates-universe',
>'20180408040914', '0', '1'], ['xenial-updates', '20180408040949', '0',
>'1'], ['xenial-backports', '20180408040307', '0', '1']],
>'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
>D: handle_action{'action': "<?xml
>version='1.0'?>\n<methodCall>\n<methodName>packages.update</methodName>\n<params>\n<param>\n<value><array><data>\n<value><array><data>\n<value><string>libpython-stdlib</string></value>\n<value><string>2.7.12</string></value>\n<value><string>1~16.04</string></value>\n<value><string></string></value>\n<value><string>amd64-deb</string></value>\n</data></array></value>\n<value><array><data>\n<value><string>python</string></value>\n<value><string>2.7.12</string></value>\n<value><string>1~16.04</string></value>\n<value><string></string></value>\n<value><string>amd64-deb</string></value>\n</data></array></value>\n<value><array><data>\n<value><string>python-minimal</string></value>\n<value><string>2.7.12</string></value>\n<value><string>1~16.04</string></value>\n<value><string></string></value>\n<value><string>amd64-deb</string></value>\n</data></array></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n",
>'version': 2, 'id': 1968}
>D: handle_action actionid = 1968, version = 2
>D: do_call packages.update([['libpython-stdlib', '2.7.12', '1~16.04',
>'', 'amd64-deb'], ['python', '2.7.12', '1~16.04', '', 'amd64-deb'],
>['python-minimal', '2.7.12', '1~16.04', '',
>'amd64-deb']],){'cache_only': None}
>D: Called update[['libpython-stdlib', '2.7.12', '1~16.04', '',
>'amd64-deb'], ['python', '2.7.12', '1~16.04', '', 'amd64-deb'],
>['python-minimal', '2.7.12', '1~16.04', '', 'amd64-deb']]
>Apt-Spacewalk: Updating sources.list
>(Reading database ... 265831 files and directories currently
>installed.)
>Removing apt-transport-spacewalk (1.0.6-4.1) ...
>Removing gufw (16.04.1-0ubuntu1.1) ...
>Removing ndiff (7.01-2ubuntu2) ...
>Removing rhnsd (5.0.4-3) ...
>Removing rhn-client-tools (1.8.26-4) ...
>Removing python-apt (1.1.0~beta1ubuntu0.16.04.1) ...
>Removing python-bs4 (4.4.1-1) ...
>Removing zenmap (7.01-2ubuntu2) ...
>Removing python-gtk2 (2.24.0-4ubuntu1) ...
>Removing python-cairo (1.8.8-2) ...
>Removing python-chardet (2.3.0-2) ...
>Removing python-rhn (2.5.55-2) ...
>Removing python-openssl (0.15.1-2build1) ...
>Removing python-cryptography (1.2.3-1ubuntu0.1) ...
>Removing python-dbus (1.2.0-3) ...
>Removing python-dmidecode (3.12.2-2) ...
>Removing python-enum34 (1.1.2-1) ...
>Removing python-gudev (147.2-3) ...
>Removing python-gobject (3.20.0-0ubuntu1) ...
>Removing python-gi (3.20.0-0ubuntu1) ...
>Removing python-gobject-2 (2.28.6-12ubuntu1) ...
>Removing python-html5lib (0.999-4) ...
>Removing python-idna (2.0-3) ...
>Removing python-ipaddress (1.0.16-1) ...
>Removing python-jabber (0.5.0-1.6) ...
>Removing python-pkg-resources (20.7.0-1) ...
>Removing python-pyasn1 (0.1.9-1) ...
>Removing python-six (1.10.0-3) ...
>Processing triggers for man-db (2.7.5-1) ...
>Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
>Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1)
>...
>Rebuilding /usr/share/applications/bamf-2.index...
>Processing triggers for mime-support (3.59ubuntu1) ...
>Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
>Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
>Processing triggers for libc-bin (2.23-0ubuntu10) ...
>Processing triggers for doc-base (0.10.7) ...
>Processing 1 removed doc-base file...
>Registering documents with scrollkeeper...
>(Reading database ... 264545 files and directories currently
>installed.)
>Preparing to unpack .../python-minimal_2.7.12-1~16.04_amd64.deb ...
>Unpacking python-minimal (2.7.12-1~16.04) over (2.7.11-1) ...
>Processing triggers for man-db (2.7.5-1) ...
>Setting up python-minimal (2.7.12-1~16.04) ...
>(Reading database ... 264545 files and directories currently
>installed.)
>Preparing to unpack .../python_2.7.12-1~16.04_amd64.deb ...
>Unpacking python (2.7.12-1~16.04) over (2.7.11-1) ...
>Preparing to unpack .../libpython-stdlib_2.7.12-1~16.04_amd64.deb ...
>Unpacking libpython-stdlib:amd64 (2.7.12-1~16.04) over (2.7.11-1) ...
>Processing triggers for doc-base (0.10.7) ...
>Processing 1 changed doc-base file...
>Registering documents with scrollkeeper...
>Processing triggers for man-db (2.7.5-1) ...
>Setting up libpython-stdlib:amd64 (2.7.12-1~16.04) ...
>Setting up python (2.7.12-1~16.04) ...
>D: Sending back response(0, 'update OK', {})
>D: do_call packages.checkNeedUpdate('rhnsd=1',){}
>D: Attempt to call an unsupported action
>packages.checkNeedUpdate('rhnsd=1',)
>D: local action status: (6, 'Invalid function call attempted', {})
>D: rpcServer: Calling XMLRPC registration.welcome_message
>
>Thank you,
>
>Paul-Andre Panon
>Senior Systems Administrator
>
>
>_______________________________________________
>Spacewalk-list mailing list
>Spacewalk-list@redhat.com
>https://www.redhat.com/mailman/listinfo/spacewalk-list

Please have a look here. Might help.

https://www.redhat.com/archives/spacewalk-list/2018-March/msg00100.html

-- 
sent from my mobile device

_______________________________________________
Spacewalk-list mailing list
Spacewalk-list@redhat.com
https://www.redhat.com/mailman/listinfo/spacewalk-list

Reply via email to