Ladies and gents:

I am trying to generate TPP from source. Here is what I did:

I have an Ubuntu 17 machine (Intel Xenon + Nvidia system).
Followed the instructions posted at 
http://tools.proteomecenter.org/wiki/index.php?title=TPP_5.1.0:_Installing_on_Ubuntu_16.04_LTS
:
1) Installed the prerequisite packages, with no errors
2) Created the suitable place to install
3) Pulled the 5.1.0 source code
4) Created the site.mk (as per the instructions)

When trying to make libgd, I started running into issues: 
First, I got this:

WARNING: 'automake-1.14' is missing on your system.
         You should only need it if you modified 'Makefile.am' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'automake' program is part of the GNU Automake package:
         <http://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <http://www.gnu.org/software/autoconf>
         <http://www.gnu.org/software/m4/>
         <http://www.perl.org/>
Makefile:337: recipe for target 'Makefile.in' failed
make: *** [Makefile.in] Error 1

I resolved it using this:
cd build/gnu-x86_64/artifacts/libpng-1.5.19

$ aclocal
$ automake
$ make

I have automake-1.15 and the above steps helped me go past that issue.

Now I am at this compile issue, which seems to be very difficult to 
resolve.  

<after setup etc, it starts to compile>

touch config.h.in

cd . && /bin/bash ./config.status config.h

config.status: creating config.h

/bin/bash ./libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.  
-DPNG_CONFIGURE_LIBPNG   -g -O2 -MT libpng15_la-png.lo -MD -MP -MF 
.deps/libpng15_la-png.Tpo -c -o libpng15_la-png.lo `test -f 'png.c' || echo 
'./'`png.c

libtool: Version mismatch error.  This is libtool 2.4.2, but the

libtool: definition of this LT_INIT comes from libtool 2.4.6.

libtool: You should recreate aclocal.m4 with macros from libtool 2.4.2

libtool: and run autoconf again.

Makefile:797: recipe for target 'libpng15_la-png.lo' failed

make[1]: *** [libpng15_la-png.lo] Error 63

make[1]: Leaving directory 
'/local/svn/release_5-1-0/build/gnu-x86_64/artifacts/libpng-1.5.19'

extern/Makefile:893: recipe for target 
'/local/svn/release_5-1-0/build/gnu-x86_64/lib/libpng.a' failed

make: *** [/local/svn/release_5-1-0/build/gnu-x86_64/lib/libpng.a] Error 2

Googling libtool issues, I am not getting anywhere.
Any help would greatly be appreciated: Has anyone tried building in Ubuntu 
17?

Thanks

-- 
You received this message because you are subscribed to the Google Groups 
"spctools-discuss" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to spctools-discuss+unsubscr...@googlegroups.com.
To post to this group, send email to spctools-discuss@googlegroups.com.
Visit this group at https://groups.google.com/group/spctools-discuss.
For more options, visit https://groups.google.com/d/optout.

Reply via email to