On 30 May 2012 18:13, Mark Brown <[email protected]> wrote: > On Wed, May 30, 2012 at 06:05:31PM +0800, Thomas Abraham wrote: >> On 30 May 2012 17:34, Mark Brown <[email protected]> wrote: > >> > Right, and there's no problem at all with using the name. The thing is >> > that there's no need to set the name at runtime since the struct device >> > being configured is always going to end up with the same name and doing >> > so is just causing confusion. The device being registered is specific >> > to the SoC already so setting the SoC name at runtime isn't needed. > >> I think I did not understand your point. There is only one instance of >> spi platform device statically defined for all Samsung platforms. The > > No there isn't. You've got things like s3c64xx_device_spi0 in > arch/arm/plat-samsung/devs.c (which you'd expect since the resources > that are passed in for memory mapping, DMA and interrupt vary with the > SoC). The bit of code I was querying just changes "s3c64xx-spi" to > "s3c6410-spi" at runtime in that structure which seems like a waste of > time.
So is the concern only with the change of device name from "s3c64xx-spi" to "s3c6410-spi"? Is there any concern with changing the name of the static spi platform device (s3c64xx_device_spi0/1/2) at runtime which then is used to select a driver data? Thanks, Thomas. ------------------------------------------------------------------------------ Live Security Virtual Conference Exclusive live event will cover all the ways today's security and threat landscape has changed and how IT managers can respond. Discussions will include endpoint security, mobile security and the latest in malware threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/ _______________________________________________ spi-devel-general mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/spi-devel-general
