On Jan 19, 2009, at 2:59 PM, Tuan Hoang wrote:

> Tuan Hoang wrote:
>> Hi,
>> I've been back-porting SQLite 3.x to CentOS 4.7 for some  
>> development work.  I've been taking the SRPMS from  
>> koji.fedoraproject.org and rebuilding them.
>> All has been fine through v3.6.7 but when I tried to recently  
>> upgrade to 3.6.10 (by just updating the SPEC file and rebuilding),  
>> the YUM updater no longer works.  In particular the python-sqlite  
>> package exits with an error when it tries to read it's cache file  
>> (I assume that it's a SQLite DB).  I checked the in-between builds  
>> and one of the changes in v3.6.8 has triggered this error.
>> Is there anyone else with a similar problem?  FWIW, I've also done  
>> this under CentOS 5.2 and it also breaks its YUM too.
>> Thanks,
>> Tuan
>> P.S.  Please reply all since I'm not subscribed to the mailing list.
> I did a little more debugging with the yum and it's use of python- 
> sqlite.  It appears that the database is not corrupt, but rather  
> that the database can't be created at all.
> The attached CREATE TABLE statements work fine with v3.6.7 and  
> before (at least the ones that I've tried).  As of v3.6.8 up through  
> v3.6.10, YUM can no longer create these tables.
> Did the string "release" suddenly become a keyword?  If so, why?

RELEASE is a command name assocated with SAVEPOINTs.  SAVEPOINT  
support was added for version 3.6.8.

The current CVS contains a work-around in the parser.  The next  
release (3.6.11) will allow "release" to be used as a column name  
without quoting.  See ticket #3590 for details. 

D. Richard Hipp

sqlite-users mailing list

Reply via email to