On 04/26/2016 09:38 AM, Petr Cech wrote:
Hi list,

this simple patch fixes talloc hierarchy in initializing negative caches
in responders.

This patch is applicable after [1].

[1]
https://www.mail-archive.com/sssd-devel@lists.fedorahosted.org/msg26515.html


Regards

Hi, just few nitpicks:

Patch 1 NEGCACHE: Adding timeout to struct sss_nc_ctx

+int responder_get_neg_timeout_from_confdb(struct confdb_ctx *cdb,
+                                          uint32_t *neg_timeout)
+{
+    int value;
+    int ret = EOK;

Please, use errno_t instead of int as a type of return code. And also do not initialize it with declaration (especially not to EOK), it tends to hide issues where you forget to set ret (I know it is not this case, but it is a bad habit).

neg_timeout

I think ncache_timeout would be a better name to use throughout the code since we shortcut "negative cache" to ncache all over the code and you remove most of neg_timeout names in following patches.



_______________________________________________
sssd-devel mailing list
sssd-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/admin/lists/sssd-devel@lists.fedorahosted.org

Reply via email to