That's what you should do. I suggest it's easier adding the getters and setters than any other solution. Under normal circumstances the form-bean won't cause any disadvantages just because of the extra properties.

On 10/17/2003 11:47 AM struts wrote:
duplication and rename it is not working because then I need to create
getter and setter methods. It should be a dummy field and the validator does
the work...
Idea ?

----- Original Message ----- From: "Adam Hardy" <[EMAIL PROTECTED]>
To: "Struts Users Mailing List" <[EMAIL PROTECTED]>
Sent: Friday, October 17, 2003 11:10 AM
Subject: Re: validation




On 10/17/2003 10:12 AM [EMAIL PROTECTED] wrote:

Question: Is there an easy way to create a dummy field for 'retype

pasword' ? And is it possible to validate this retype 'password field' with the validator plugin ? If so how ?

Thanks !

Yes it's easy. Just duplicate the code for the password field, but rename it retypePassword.

You can validate it using the 'twofields' validator, but that is not in
the struts 1.1 release. Check the archives for links to pages with
instructions for installing it, or check the validator nightly builds,
it might be in there. (I'm not sure).


--
struts 1.1 + tomcat 5.0.12 + java 1.4.2
Linux 2.4.20 RH9


--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]



Reply via email to