> 2016.09.20 09:21:35 LOG5[ui]: stunnel 5.35 on x86_64-apple-darwin15.4.0 platform
> 2016.09.20 09:21:35 LOG5[ui]: Compiled with OpenSSL 0.9.8zd 8 Jan 2015
> 2016.09.20 09:21:35 LOG5[ui]: Running  with OpenSSL 0.9.8zh 14 Jan 2016

If I use that verbatim I get the error:
2016.09.21 06:46:46 LOG3[ui]: SSL_connect: 140740BF: error:140740BF:SSL
routines:SSL23_CLIENT_HELLO:no protocols available
In fact it seems like the only security protocol available to me
is TLSv1, as the presence of the NO_SSLv2 and NO_SSLv3 options have no
effect (which makes sense: I understand that Stunnel doesn’t use SSL v2
or v3 these days).  I don’t know if this indicates something untoward..

TLS 1.1 and 1.2 are supported by OpenSSL version > 0.9.8
With OpenSSL 0.9.x can be negotiated only TLSv1, so you can’t set option NO_TLSv1, you're right. Given that your version of OpenSSL is obsolete, it’s best that you upgrade to the latest version.

Regards.

---
Ta wiadomość została sprawdzona na obecność wirusów przez oprogramowanie 
antywirusowe Avast.
https://www.avast.com/antivirus

_______________________________________________
stunnel-users mailing list
stunnel-users@stunnel.org
https://www.stunnel.org/cgi-bin/mailman/listinfo/stunnel-users

Reply via email to