> On Mar 13, 2018, at 5:51 AM, Lubomir I. Ivanov <neolit...@gmail.com> wrote:
>> 
>> Tried the map facility on Android 7.0 on a Galaxy S6. I could not fault it
>> in any way. Tried lots of things but it appeared rock stable.  This included
>> switching between map mode and satellite image mode. Lubomir, you are magic.
>> Two issues:
>> 
>> 1) It would help if, like the desktop version, the map initialised on the
>> most recent dive location.
>> 
> 
> the desktop version dive list and map are more tightly linked.
> on desktop the map updates immediately and also an entry is selected
> in the dive list.
> on mobile you have to click "map it" from dive details to move the map
> to a new marker and a dive list entry is not selected on startup.
> 
> if you want the most recent dive to be selected on the map it also
> makes sense for it to be selected in the dive list.
> 
> currently the map initializes over Greenwhich, but it's zoomed in.
> maybe it should be zoomed out to see the entire globe.

I think it would make sense to start the app with the last dive selected.

>> 2) The menu options do not all work. If I:
>> 
>>    a) Select a particular dive site on the map and go to the dive list, it
>> goes to dives at an an appropriate dive site in the dive list. The tests
>> that I did went to the most recent dives at that site. Excellent. :-)
>> 
>>    b) Open location in Google Maps, then an irrelevant location about 800
>> km away is opened.
>> 
> 
> strange, cannot confirm. just tried zooming in very deep from the
> subsurface map and opening in google map reproduced the location
> exactly.

Is this a locale problem again? Are we sending a localized string to Google
maps by mistake?

>>    c) Copy location to clipboard (decimal) then coordinates for a
>> *different* irrelevant location is copied to clipboard.
>> 
>>    d) Copy location to clipboard (sexagesimal) then a *another different*
>> random location is copied to the clipboard.
>> 
> 
> c), d) same as above. cannot confirm.

Can you give an example of the location you are at, and the string that is
copied to the clipboard? That might help us figure out what's wrong.

>>    e) Obviously the option "Select visible dive locations" does not work.
>> This is probably not because of faulty map functions but because of the way
>> the dive list works at the moment that does not make this operation
>> possible.
> 
> works for me. zoom over a single marker that is not selected. run
> "Select visible dive locations" and the marker is selected.
> it follows the same logic as a) - only a single dive in the list is selected.

And if multiple markers are in the window, what's the expected behavior?

/D
_______________________________________________
subsurface mailing list
subsurface@subsurface-divelog.org
http://lists.subsurface-divelog.org/cgi-bin/mailman/listinfo/subsurface

Reply via email to