. I had the same problem using traci4matlab as adama. He asked about this
error in 12th of July 2016 in the following link:
I couldn't find an answer. I tried to figure it out myself and I think I
have found the solution:
In the manual to traci4matlab it is stated that one should add the
following lines to the sumo configuration file of the project which
initiates sumo on port 8813:

    <remote-port value="8813"/>

It is also noted that port 8813 is the default port and you can use the
following function after running sumo:


But here we have the error reported by adama in the link I provided.
I looked in the traci4matlab's init.m file and in the new version of the
file available at the following github page:

we have the following line:

 p.addOptional('port', 8873, @(x)isnumeric(x) && length(x)==1)

It seems that they have changed the default port to 8873 without changing
the manual!
By setting your port to 8873 in the sumocfg file the problem is solved.
I think I don't have access to sumo-devel list so I posted the solution
here in the hope that it will be useful.
I also proposed a change on github in the following link:


*Aboozar Roosta*
Msc. Student of Electrical Engineering - Control
School of Electrical and Computer Engineering,
Tarbiat Modares University (TMU), Tehran, Iran.
Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
sumo-user mailing list

Reply via email to