Hi Oleg,

I tried replacing the devicetree.dtb file in the nand folder from 
elphel393_20180511 with the one you sent. I tried the 
ipaddress/update_software.html tool again but nothing changed. When I log into 
the elphel from minicom and try ifconfig I still only get the local address at This is on a Rev C board. Do you have any other ideas?

Also I meant to send the previous email from my Redzone email so I'll CC myself 
to this chain.


Mohamed Morsy

From: Oleg <support-list@support.elphel.com>
Sent: Tuesday, December 4, 2018 2:51 PM
To: Morsy, Mohamed K
Cc: elphel support-list
Subject: Re: [Elphel-support] Elphel 393 Nand upgrade

Hi Mohamed,

I think it's not related.

Most likely you need an updated device tree (devicetree.dtb). The newest boards 
are revC - they have a different PHY reg address compared to revB (and older). 
The recovery cards came with updated devicetree - and so, the network is 
The revision letter is printed near the network connector on top of the board. 
For revC - try devicetree.dtb from the attachment.

fix_net_config.tar.gz - just moves network configuration from 
/etc/elphel393/init_elphel393.py to /etc/network/interfaces which is a more 
conventional place for linux. And it will be included in the next release.

I'm having trouble upgrading the NAND memory on an elphel 393. I've tried it 
with multiple boards. I used the ipaddress/update_software.html tool. When I 
flash the board, I shut it down, remove the uSD card, and reboot it. But it 
doesn't boot up correctly. I'm able to log in on minicom but when I try 
ifconfig I find that the board doesn't have an ip address. Do you know how to 
resolve this issue? I noticed there's a recent upload at 
 called fix_net_config.tar.gz. Is that related to my issue?

Mohamed Morsy
RedZone Robotics
Support-list mailing list

Support-list mailing list

Reply via email to