Matthew Toseland a écrit :
On Monday 15 June 2009 12:58:06 Jean-Claude Féret wrote:
for a bit more than a year, I used Freenet (discontinuously but regularly), without problems on Mac PPC Tiger. Now, I updated my old machine to an iMac-Intel, and, trying to follow the advices, downloaded the last "Freenet.jnlp", but, even if it arrived correctly on my desk, it doesn't start the install, neither automatically, nor by double-clicking it.

So, continuing to follow the instructions, and since the first steps didn't work, I went to Linux instructions, and entered in Terminal the commands how they are given to DL the new install jar.

wget -O new_installer_offline.jar
java -jar new_installer_offline.jar

It didn't work... so, I extracted the first part of it (URL) and Dlded it by hand with FireFox.

I must say that I still am a bit bepuzzled with the content of it, that doesn't seem to ressemble the sort of packages to be installed through Terminal... no file called "install" nor "istall info", giving the steps to follow… nor file in it looking somehow a bit alive (.sh, .jar, .exec...) so, I tried anyway to follow the commands given in the tut, but it didn't work either...

What exactly happened after you typed "java -jar new_installer_offline.jar" ? 
What error message did you see? What version of Java do you have installed on the Mac? 
Freenet needs Java 1.5 now, some versions of OS/X might have 1.4?
Next thing, since I'm on mac-Intel, I tried to install it on the xp pro side of my computer...

It downloaded OK, and installed fine (there is already i2p working fine on this xp), but now, and after few hours, it doesn't seem to be able to connect to nodes... I opened the proper holes in the router from my modem, and it didn't managed either... (I choosed *normal *at all security levels, meaning that it could connect to unknowns), and also gave momentaryly my IP (bybassing proxy)... besides this, I don't think that for this xp pro there is any firewall... have to investigate though to see if my mac Firewall works for it (really don't think so, neither LittleSnitch)...

This is very strange. If you go to Status and then to "Connections to Strangers", there are no connections? 
Are there any nodes listed as "disconnected", "busy", "backed off", etc?

Can you post your wrapper.log? (File in the dir Freenet is installed into)
I must say however that I would very much prefer to have freenet installed and working on Leopard, not fearing then any virus and such problems with it... I know, if XP would get infected I would only have to reinstall it... since I don't keep much folders in it... (at the beginnig, I'd try to see if, been on Mac, it would be protected from such attacs and infections, and, just for the experiment went to a site where I new to find bugs, and... ;-) … well I had to reinstall it... so now, I'm being a bit careful.

Next thing, if I can't find proper solutions, would be to install Freenet on the linux part of my OS (there is already stealthnet on Kubuntu, working fine) and this has anyway, like mac, the Unix security level...

I'd be grateful for a little advice... thanks.

Support mailing list
Unsubscribe at
Hi Andrew, I realize that I mis to end you one of the things you were asking for:

the wrapper.log... but if it is easy to locate on Linux or Mac (just go into 
the applications dir, and open the freeNet folder, and even if on an app, right 
clic to show the inside of the app... it seems to be on Windows, an other sort 
of a story... since the application folder shows only probably aliasses or 
controls to the proper app... and not the complete app folder anyway... so how 
the hell on windows is one going into an apps folder and fiddling with its guts?

Support mailing list
Unsubscribe at

Reply via email to