> Edit the "wrapper.java.command=java" line
> in the wrapper.conf file.

I must be doing something wrong.
I started from scratch by deleting the freenet directory followed by a "tar 
-xzvf freenet...tar.gz".
Then, I changed wrapper.con file as follow:

I did an "ls $HOME/bin/java" to confirm.
Then, I ran "$HOME/bin/java -version" to confirm it is SUN's 1.6 version.

When I tried to run "./run.sh start", it gave me the default Linux Open JVM 
(that I cannot change since I don't have root access).

I started from scratch again, "tar, followed by modify wrapper.conf".
This time, I went into "run.sh" and every call to java, I changed to 
Then, I did the same with ./freenet/bin/1run.sh and changed very called to java 
to $HOME/bin/java.

At this point I did a "cd ./freenet" and typed:

Everything was looking great until I got a message:  crontab command not found. 
 Well, I don't have crontab and I won't be getting it from my hosting company.
I verified by typing "which crontab", the failing command.

I thought, well, I will just have to start freenet (./run.sh start) every time 
I reboot (or put in my own profile).

I proceeded to do a "./run.sh status".
I was told freenet was not running.
I proceeded to "./run.sh start"

Got the following messages:
Starting freenet 0.7

When I do the ./run.sh status:  no luck, it is not running.

When I look at "freenet.ini", it is very small with only 7 lines.

By the way, for some reason I can only have 128M for my JVM.
I went into wrapper.conf and the line the comments tell me to change (I removed 
the # in the 1st column), I ended the line with "MaxPermSize=128m".

When I looked at ./log/wrapper.log, there is a message saying unable to start 
JVM.  It is repeated quite a few times along with no such file or directory.
I doubled checked that I can run Java:
$HOME/bin/java -version

Could it be that "$HOME" is causing problems?
Could it be that I need to type "/$HOME" in all the files?

I promise to put together the documentation once we get this project going.

Thank you all for your help so far.

Support mailing list
Unsubscribe at http://emu.freenetproject.org/cgi-bin/mailman/listinfo/support
Or mailto:support-requ...@freenetproject.org?subject=unsubscribe

Reply via email to