On 29-03-15 19:35, Wolfram Goetz wrote:
> 
> I always got these out memory errors when I tried to run a 3TiB node under 
> Windows 7 64-bit, regardsless of the said settings. When I switched to Linux 
> (Kubuntu 14.04) it worked immediately. Could it also depend on the java 
> version? I'm using OpenJDK under Linux now.

I'm not sure it is related to the Java version at hand. What I suspect
to have been the culprit in your situation, is the architecture of the
Java installation you employed on your Windows machine.

32-bit applications on Windows can only use 2 GiB of virtual memory (or
3 GiB with the large address awareness flag set in the executable
image), and Java is quite liberal in its virtual memory usageā€¦

Oracle recommends using a 32-bit Java under most conditions, even on a
64-bit Windows installation. On 64-bit Linux, you'll probably have had a
64-bit Java by default, on Windows, it might have been a 32-bit one.

If you can reproduce this on a 64-bit JVM (you can check the version and
architecture with the command `java -version'), please file a bug report.

-- Bert

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Support mailing list
Support@freenetproject.org
http://news.gmane.org/gmane.network.freenet.support
Unsubscribe at http://emu.freenetproject.org/cgi-bin/mailman/listinfo/support
Or mailto:support-requ...@freenetproject.org?subject=unsubscribe

Reply via email to