> On 12 Jan 2018, at 07:15, Chris Eidhof via swift-evolution > <swift-evolution@swift.org> wrote: > > Hey SE! > > When we have a bunch of nested structs: > > struct Sample { > var bar: Bar > } > > struct Bar { > var show: Bool > } > > var foo = Sample(bar: Bar(show: false)) > > It can be repetitive to toggle a deeply nested boolean: > > foo.bar.show = !foo.bar.show // duplication > > I sometimes add a `toggle` extension on `Bool` > > extension Bool { > mutating func toggle() { > self = !self > } > } > > This allows you to write the same code without duplication, and makes the > intent clearer: > > foo.bar.show.toggle() > > In other languages, I don't think the `toggle` would make as much sense, but > the mutable self makes this very useful. > > After I posted it on Twitter, it turns out I'm not the only one: > https://twitter.com/PublicExtension/status/730434956376346624 > <https://twitter.com/PublicExtension/status/730434956376346624> > > I would have gone straight to a proposal, but I think we can do some > bikeshedding about the name of `toggle`?
Out of all the versions I heard, toggle is the one that makes the most sense to me. > -- > Chris Eidhof > _______________________________________________ > swift-evolution mailing list > swift-evolution@swift.org > https://lists.swift.org/mailman/listinfo/swift-evolution
_______________________________________________ swift-evolution mailing list swift-evolution@swift.org https://lists.swift.org/mailman/listinfo/swift-evolution