> On Jan 13, 2018, at 1:40 PM, Erica Sadun <er...@ericasadun.com> wrote:
>> On Jan 9, 2018, at 10:22 PM, Brent Royal-Gordon via swift-evolution 
>> <swift-evolution@swift.org> wrote:
>> If we can't do this, I think we should call it something like `PairArray` or 
>> `KeyValueArray` 
> Or "KeyValueList", which avoids both "Dictionary" and "Array" words.

I specifically want "Array" in the name, because this type has the same 
semantics as an array:

* RandomAccessCollection
* Contiguous, zero-based Int indices
* Isn't currently, but could be, MutableCollection and 

Brent Royal-Gordon

swift-evolution mailing list

Reply via email to