Thanks for your review. Here is the updated webrev:
From: Pankaj Bansal
Sent: Friday, April 6, 2018 3:04 PM
To: Krishna Addepalli <krishna.addepa...@oracle.com>; firstname.lastname@example.org
Subject: RE: <Swing Dev>  [JDK-8201173] Remove duplicated code in
The code changes look fine to me.
Just one suggestion. I think you don't need to create custom UpdateFunction
functional Interface here. Java has BiConsumer functional interface, which does
what you are trying to do here.
From: Krishna Addepalli
Sent: Thursday, April 5, 2018 9:09 PM
Subject: <Swing Dev>  [JDK-8201173] Remove duplicated code in
Please review a fix for
There is the duplication of code in fireContentsChanged, fireIntervalAdded,
fireIntervalRemoved functions, barring an int parameter and a function call.
Moved the common code into a function called fireUpdates, and defined a
functional interface, so that each function can pass its own lambda that does
the requisite function call.
I have run the tests for JList and JComboBox and observed no new failures.