I have a couple of pcaps that I am trying to generate a cachefile from, but
each time I run tcpprep it errors saying:

$ tcpprep --auto=router --cachefile=example.cache --pcap=example.pcap

reading from file -, link-type EN10MB (Ethernet)

Fatal Error:
poll() timeout... tcpdump seems to be having a problem keeping up
tcpdump: pcap_loop: truncated dump file; tried to read 37383 captured
bytes, only got 94

This is occurring with a number of different pcaps that have been created
using both tcpdump and wireshark.

Is there any additional troubleshooting I can perform to understand what is
happening? Is increasing TCPDUMP_POLL_TIMEOUT likely to help? I tried
exporting this as an environment variable but it appears to have no effect,
how can this be modified at runtime?


Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Tcpreplay-users mailing list
Support Information: http://tcpreplay.synfin.net/trac/wiki/Support

Reply via email to