Looking further into this and the previous error message could be
misleading. The code producing this error appears to be called only because
I have provided the verbose flag. Without the verbose flag the command
completes, but subsequently when using this cache file with tcprewrite I
get the following error:

> Fatal Error: Cache data length (256 bytes) doesn't match cache header
(1440788 bytes)

It appears that there is some issue generating this cache file and I am
unclear how to proceed. Any help would be appreciated.

Thank you,

Peter

On 5 August 2017 at 13:54, Peter Gallagher <gallagher.pe...@gmail.com>
wrote:

> I have a couple of pcaps that I am trying to generate a cachefile from,
> but each time I run tcpprep it errors saying:
>
> ```
> $ tcpprep --auto=router --cachefile=example.cache --pcap=example.pcap
> --verbose
>
> reading from file -, link-type EN10MB (Ethernet)
>
> Fatal Error:
> poll() timeout... tcpdump seems to be having a problem keeping up
> Try increasing TCPDUMP_POLL_TIMEOUT
> tcpdump: pcap_loop: truncated dump file; tried to read 37383 captured
> bytes, only got 94
> ```
>
> This is occurring with a number of different pcaps that have been created
> using both tcpdump and wireshark.
>
> Is there any additional troubleshooting I can perform to understand what
> is happening? Is increasing TCPDUMP_POLL_TIMEOUT likely to help? I tried
> exporting this as an environment variable but it appears to have no effect,
> how can this be modified at runtime?
>
> Thanks,
>
> Peter
>
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Tcpreplay-users mailing list
Tcpreplay-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/tcpreplay-users
Support Information: http://tcpreplay.synfin.net/trac/wiki/Support

Reply via email to