Hi,

My wireless card AR9485 is not recognized by kernel (5.5). I'm having the
error following error message:
"Atheros AR9485" rev 0x01 at pci2 dev 0 function 0 not configured

As far as I understand it means it's not supported but I can find a 2012
email on tech list mentionning the ar9485 device in athn driver.

I find out in athnreg.h:
#define AR_SREV_VERSION_9485            0x240
#define AR_SREV_REVISION_9485_10        1

So it looks like it should be supported?

pcidump -v give me:
 2:0:0: Atheros AR9485
0x0000: Vendor ID: 168c Product ID: 0032
0x0004: Command: 0007 Status: 0010
 0x0008: Class: 02 Subclass: 80 Interface: 00 Revision: 01
0x000c: BIST: 00 Header Type: 00 Latency Timer: 00 Cache Line Size: 10
 0x0010: BAR mem 64bit addr: 0x00000000f1500000/0x00080000
0x0018: BAR empty (00000000)
0x001c: BAR empty (00000000)
 0x0020: BAR empty (00000000)
0x0024: BAR empty (00000000)
0x0028: Cardbus CIS: 00000000
 0x002c: Subsystem Vendor ID: 144d Product ID: 4105
0x0030: Expansion ROM Base Address: ffff0000
0x0038: 00000000
 0x003c: Interrupt Pin: 01 Line: 0b Min Gnt: 00 Max Lat: 00
0x0040: Capability 0x01: Power Management
0x0050: Capability 0x05: Message Signaled Interrupts (MSI)
 0x0070: Capability 0x10: PCI Express
        Link Speed: 2.5 / 2.5 GT/s Link Width: x1 / x1

pcidump -x give me:
 2:0:0: Atheros AR9485
0x0000: 0032168c 00100007 02800001 00000010
0x0010: f1500004 00000000 00000000 00000000
 0x0020: 00000000 00000000 00000000 4105144d
0x0030: ffff0000 00000040 00000000 0000010b

if any body can help me get it works, thanks (actually I try to play a
little bit with the value in athnreg.h but it's not working :-) I'm not
really a kernel developer so obviously I miss something.

Regards,
Sebastien

Reply via email to