>
>
> You could try adding the ID to the athn driver to get it to match:
>
> Index: if_athn_pci.c
> ===================================================================
> RCS file: /cvs/src/sys/dev/pci/if_athn_pci.c,v
> retrieving revision 1.14
> diff -u -p -r1.14 if_athn_pci.c
> --- if_athn_pci.c       6 Dec 2013 21:03:03 -0000       1.14
> +++ if_athn_pci.c       8 May 2014 23:07:17 -0000
> @@ -98,7 +98,8 @@ static const struct pci_matchid athn_pci
>         { PCI_VENDOR_ATHEROS, PCI_PRODUCT_ATHEROS_AR2427 },
>         { PCI_VENDOR_ATHEROS, PCI_PRODUCT_ATHEROS_AR9227 },
>         { PCI_VENDOR_ATHEROS, PCI_PRODUCT_ATHEROS_AR9287 },
> -       { PCI_VENDOR_ATHEROS, PCI_PRODUCT_ATHEROS_AR9300 }
> +       { PCI_VENDOR_ATHEROS, PCI_PRODUCT_ATHEROS_AR9300 },
> +       { PCI_VENDOR_ATHEROS, PCI_PRODUCT_ATHEROS_AR9485 }
>  };
>
>  int
>
> No guarantees as to whether this is sufficient, or if further
> work is needed, but it will at least get the device picked up by
> the athn driver.
>

I did and It's doing what expected: card is detected but ifconfig athn0
scan does not give me any result and it should since I'm far from one meter
of the AP.

Direct configuration give nothing either:
$ ifconfig athn0 newid LSA wpapsk '***'
ifconfig: newid: bad value

$ dmesg|grep athn0
athn0 at pci2 dev 0 function 0 "Atheros AR9485" rev 0x01: apic 2 int 16
athn0: AR9485 rev 1 (1T1R), ROM rev 0, address 18:67:b0:8f:d1:58
athn0: could not initialize calibration
athn0: could not initialize calibration
athn0: unable to reset hardware; reset status 60
athn0 at pci2 dev 0 function 0 "Atheros AR9485" rev 0x01: apic 2 int 16
athn0: AR9485 rev 1 (1T1R), ROM rev 0, address 18:67:b0:8f:d1:58
athn0: could not initialize calibration

So I'm stuck with finding old usb hardware or waiting for a kind developer
to have time and will to get my card supported ;-)

Thanks for your help,
Sébastien

Reply via email to