On Fri, Jan 20, 2017 at 01:26:11PM +1000, Martin Pieuchot wrote:
> On 20/01/17(Fri) 03:04, Claudio Jeker wrote:
> > I want to use art routing tables with pf addrs and not sockaddrs.
> > Art itself does not care but the API requires sockaddr pointers in some
> > places. This changes those to void *.
> > 
> > OK? This is step 2 to a new pf_table backend.
> 
> What's the problem with uint8_t?  If possible I'd prefer keeping that
> type since it's clear that we're dealing with bytes.

IIRC I did it to reduce the amount of casts needed. You can pass the
address of a struct in_addr or similar this way without having to cast.
 
> I also think that ``an_dst'' is no longer used and can die.  The value
> attached to an art_node is now ``an_rtlist''.  This might be renamed and
> we could use a "void *" since you're not going to use list for pf.
> 
> That means we could fold ``an_rtlist'' in the union and reduce the size
> of 'struct art_node'.
> 
art_get() still sets it unconditionally. I have nothing against olding
an_rtlist in but think we should make sure that you can use art without
multipath...

-- 
:wq Claudio

Reply via email to