În 21 iunie 2020 16:30:43 EEST, Theo de Raadt <dera...@openbsd.org> a scris: >Paul Irofti <p...@irofti.net> wrote: > >> If you change the name to rdtsc_ordered(), OK. > >That is a weaker name. > >Ordered in what way, at what level; ordered against what? > >This is using a specific pipeline ordering known as lfence. >So it might as well say lfence. That is the technical name for >that type of ordering. Being vague is unhelpful. Ok then, if you think that's best.
- lfence for rdtsc Mark Kettenis
- Re: lfence for rdtsc Paul Irofti
- Re: lfence for rdtsc Robert Nagy