"Arto V. Viitanen" wrote:
> Alex Farrell WA15 consultant wrote:
> >
> > Hi all,
> >
> > Well, I'm sure *someone* must have seen the error:
> >
> > Error opening terminal: generic.
> >
> > when running texconfig.
> >
> > I make'd teTeX v1.0.7, with the texmf dir correctly identified, and all
> > was successful. However, make install fails with the above error when it
> > runs texconfig. Any suggestions would be very much appreciated.
> >
> Following gives same error message:
> % TERM=generic dialog --yesno "Hello" 3 40
> zsh: can't find termcap info for generic
> Error opening terminal: generic.
> If you look at the texconfig, it uses the dialog program
> (atleast on Linux and BSD). So, it seems you have not defined
> your TERM environment variable. Try xterm or vt100, depending on
> what kind of terminal (emulator) you use.

Thanks for the tip, but actually TERM was set to "xterm". The problem
has now gone away - it turns out that it was simply a matter of
downloading tetex-base.tar.gz from a cpan site, rather than using the
one specified in the README in the teTeX distribution. Annoying, but at
least it works now.


Alex Farrell
org:Alcatel;Carrier Internetworking Division - WA15
email;internet:[EMAIL PROTECTED]
title:HdS Support Engineer
fn:Alex Farrell

Reply via email to