On 2002-05-06, Paul A Sand wrote:

> On Mon, May 06, 2002 at 07:40:23PM +0200, Svend Tollak Munkejord wrote:
> > I am trying to install the latest teTeX beta. On SuSE Linux 7.2 it compiles
> > all right, but on Tru64 Unix V5.1, using GNU make and gcc, "make all"
> > exits with the following error message:
> I haven't tried the beta, but my notes claim this about the last
> version:
>     o  I used cc and cxx instead of gcc.
>       i.e., my configure step is something like
>           env CC=cc CXX=cxx ./configure --prefix=/usr/local/teTeX

Thanks a lot for the tip. Unfortunately, I was not able to build even the
old teTeX 1.0. I tried this:

env CC=cc CXX=cxx CFLAGS='-O0 -g' sh -c './configure \
--prefix=/usr/local/share/teTeX >configure.log 2>&1' && \
sh -c 'make all >all.log 2>&1' &

and got the following error message:

cxx -o pdftex pdftexini.o pdftex0.o pdftex1.o pdftex2.o pdftexextra.o
pdftexdir/libpdf.a ../../libs/libpng/libpng.a ../../libs/zlib/libz.a
pdftexdir/xpdf-0.80/xpdf/pdftoepdf.a pdftexdir/xpdf-0.80/goo/libGoo.a
lib/lib.a ../kpathsea/STATIC/libkpathsea.a -lm
load_compressed_file could not malloc 25820987655. bytes for
make[2]: *** [pdftex] Error 1
make[2]: Leaving directory
make[1]: *** [all] Error 1
make[1]: Leaving directory `/usr/local/share/src/teTeX/teTeX-1.0/texk'
make: *** [all] Error 1

I tried with and without setting the CFLAGS, and both with GNU and Tru64
ar. Using GNU ar gave a different error.

The error message was similar for the latest teTeX beta. Do you understand
any of it?

Svend Tollak Munkejord

Reply via email to