Has it always been the case that updates will fail if the indexing server is down? (Incidentally this is with ThinkingSphinx.remote_sphinx = true)
It seems very impractical that your entire application will not work if the server is not running... How would I ever reindex the the core - 40mm documents takes hours.. ----- Riddle::ConnectionError (Connection to $SERVERNAME on 3312 failed. Connection refused - connect(2)): riddle (1.1.0) lib/riddle/client.rb:540:in `rescue in initialise_socket' riddle (1.1.0) lib/riddle/client.rb:528:in `initialise_socket' riddle (1.1.0) lib/riddle/0.9.9/client.rb:8:in `initialise_connection' riddle (1.1.0) lib/riddle/client.rb:474:in `open_socket' riddle (1.1.0) lib/riddle/client.rb:501:in `connect' riddle (1.1.0) lib/riddle/client.rb:559:in `request' riddle (1.1.0) lib/riddle/client.rb:209:in `run' riddle (1.1.0) lib/riddle/client.rb:316:in `query' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/search.rb:322:in `block (2 levels) in populate' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/search.rb:321:in `block in populate' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/search.rb:437:in `call' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/search.rb:437:in `retry_on_stale_index' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/search.rb:318:in `populate' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/search.rb:131:in `method_missing' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/search_methods.rb:395:in `search_for_id' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/active_record/attribute_updates.rb:46:in `update_index' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/active_record/attribute_updates.rb:23:in `block in update_attribute_values' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/active_record/attribute_updates.rb:16:in `each' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/thinking-sphinx-1.3.20/ lib/thinking_sphinx/active_record/attribute_updates.rb:16:in `update_attribute_values' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/after_commit-1.0.7/lib/ after_commit/connection_adapters.rb:129:in `block in trigger_after_commit_callbacks' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/after_commit-1.0.7/lib/ after_commit/connection_adapters.rb:128:in `each' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/after_commit-1.0.7/lib/ after_commit/connection_adapters.rb:128:in `trigger_after_commit_callbacks' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/after_commit-1.0.7/lib/ after_commit/connection_adapters.rb:36:in `commit_db_transaction_with_callback' /usr/local/ruby19/lib/ruby/gems/1.9.1/gems/after_commit-1.0.7/lib/ after_commit/connection_adapters.rb:12:in `transaction_with_callback' app/controllers/venues_controller.rb:84:in `block in update' app/controllers/venues_controller.rb:83:in `update' -- You received this message because you are subscribed to the Google Groups "Thinking Sphinx" group. To post to this group, send email to [email protected]. To unsubscribe from this group, send email to [email protected]. For more options, visit this group at http://groups.google.com/group/thinking-sphinx?hl=en.
