Hi Mario, > If you hack the core prototype chain, be sure you pass all existing tests. >
How? I literally have no idea. If you could test that for me or explain the process, that would be grand. Every existing plugin has expectations about the core functions ;) > I know, I realised that simply overwriting so core functions without hijacking can have nasty side-effects with other plugins who wish to do the same. So either it will get its functionality at the expense of mine or vice versa. So, these are the functions that have not been hijacked... - getReferringTiddlers - reverseLookup However, in this case, the only 'better' option would be to hijack all of them and them to pretty much duplicate the code and only run the core stuff when mine doesn't apply. But this isn't good enough either because I might deprive some other plugin whose name is lower in the foodchain from kicking in, i.e. by not running core function it wanted to hijack as well, which I took away. But then, there always is the option to retrofit my plugin or that other one to make both compatible. Long story short, I think this should definetely end up in one of the next releases of TiddlyWiki classic rather than in a plugin (of mine). Renaming tiddlers has been a pain point like forever. So, having it out there might perhaps help push the issue, precisely because in the form of a perhaps soonish rather popular plugin it has too much of a potential to cause compatiblility hickups. So, what do you think, perhaps rather make a new branch "rename tiddlers" and a pull request for core changes? Again, as for (making / writing) tests, I wouldn't know yet. Tobias. -- You received this message because you are subscribed to the Google Groups "TiddlyWiki" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]. To post to this group, send email to [email protected]. Visit this group at http://groups.google.com/group/tiddlywiki. For more options, visit https://groups.google.com/groups/opt_out.

