On Mon, Jan 14, 2013 at 4:30 AM, Guus Sliepen <[email protected]> wrote: > On Sun, Jan 13, 2013 at 05:06:57PM -0600, Rob Townley wrote: > >> c:\APPS\TINC\tincd.exe --mlock --net=mynet --config=C:\APPS\tinc\mynet >> >> Without --mlock, the service starts OK. >> With --mlock, the service fails to start. > > It should print this error message: > > mlockall() not supported on this platform > > Does it not show you that error message? Perhaps the error message should > mention you cannot use the "--mlock" option on Windows. In any case, I'll make > note in the manual that this option is not supported on all platforms. > > -- > Met vriendelijke groet / with kind regards, > Guus Sliepen <[email protected]> > > _______________________________________________ > tinc mailing list > [email protected] > http://www.tinc-vpn.org/cgi-bin/mailman/listinfo/tinc >
i usually import a tincd.reg file with the --debug and --mlock and --log parameters. When tinc.myvpn is started from services.msc or sc start tinc.myvpn, the only error is the windows error that tinc could not be started. Nothing in EventLog either. However, i did just try tincctl.exe --mlock --net=myvpn start and yes, that does indeed show the error message. The frustrating thing at the moment is that using tincctl.exe stop not only stops the service but deletes the service from the registry. It recreates it when tincctl.exe start is called, but it prevents production use. Is there a way to make it so that the service is not deleted when stopped? And when init, it checks if the service exists and timeout confirms that you want to overwrite the old service entry? _______________________________________________ tinc mailing list [email protected] http://www.tinc-vpn.org/cgi-bin/mailman/listinfo/tinc
