On Wed, Jan 23, 2013 at 10:51:26AM -0800, CoderForFun wrote: > Basically this node is a VPS with two IPs, on a single eth0, with eth0 -> > IP1, eth0:1 -> IP2. IP1 and IP2 are on > different subnets, so they have two different gateways. This is a CentOS 5 > box, so I've edited ifcfg-eth0 and > ifcfg-eth0:1 and manually added GATEWAY=n.n.n.n statements for each IP (in > each ifcfg-<interface> file). > > But, TINC is unable to ping any other hosts. It seems to be a route problem > caused by multiple default gateways, > one for each real public IP / subnet. May I need to add a default gateway for > TINC ?!? How to do that ??? > > Destination Gateway Genmask Flags Metric Ref Use Iface > xxx.yyy.zzz.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0 > 10.8.0.0 0.0.0.0 255.255.255.0 U 0 0 0 tun0 > xxx.yyy.vvv.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0 > 169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0 > 0.0.0.0 xxx.yyy.zzz.1 0.0.0.0 UG 0 0 0 eth0 > 0.0.0.0 xxx.yyy.vvv.1 0.0.0.0 UG 0 0 0 eth0
Hm, multihoming is not trivial, it could be that your VPS has trouble making
outgoing connections. But in any case, try starting tinc in the foreground with
debugging enabled:
tincd -n <netname> -d5 -D
That should tell you what tinc is trying to do and any errors it encounters. If
that doesn't help you, please send a copy of the debug output, and your
tinc.conf, tinc-up and host config files.
--
Met vriendelijke groet / with kind regards,
Guus Sliepen <[email protected]>
signature.asc
Description: Digital signature
_______________________________________________ tinc mailing list [email protected] http://www.tinc-vpn.org/cgi-bin/mailman/listinfo/tinc
