#20379: Can't initially connect to bridges after new network connection
------------------------------------------+----------------------
     Reporter:  qbi                       |      Owner:  tbb-team
         Type:  defect                    |     Status:  new
     Priority:  Medium                    |  Milestone:
    Component:  Applications/Tor Browser  |    Version:
     Severity:  Normal                    |   Keywords:
Actual Points:                            |  Parent ID:
       Points:                            |   Reviewer:
      Sponsor:                            |
------------------------------------------+----------------------
 I'm running TBB 6.5a3 with 6 obfs4 and 3 scramblesuit bridges. When I
 change networks (e.g. home -> work or cable -> wifi) and thus get new IP
 addresses, all URLs I visit in TBB time out. I tried to reload the URLs
 three or four times with the same result. But if I open the network
 settings, go to the bridge settings and press the OK button, everything
 works. So I make no changes to the settings. I just open them and close
 them.

 I copied the log from the TBB interface (I changed the original
 fingerprint and IP):

 {{{
 12.10.2016 12:28:51.200 [NOTICE] Bootstrapped 5%: Connecting to directory
 server
 12.10.2016 12:28:51.200 [NOTICE] Bootstrapped 10%: Finishing handshake
 with directory server
 12.10.2016 12:28:51.600 [WARN] Proxy Client: unable to connect to
 64.137.204.112:50979 ("general SOCKS server failure")
 12.10.2016 12:28:52.000 [NOTICE] Bootstrapped 15%: Establishing an
 encrypted directory connection
 12.10.2016 12:28:52.300 [NOTICE] Bootstrapped 20%: Asking for
 networkstatus consensus
 12.10.2016 12:28:52.800 [NOTICE] new bridge descriptor 'Unnamed' (fresh):
 FP1~NAME1 at IP1
 12.10.2016 12:28:52.800 [NOTICE] I learned some more directory
 information, but not enough to build a circuit: We have no usable
 consensus.
 12.10.2016 12:28:53.200 [NOTICE] Bootstrapped 25%: Loading networkstatus
 consensus
 12.10.2016 12:28:53.300 [WARN] Proxy Client: unable to connect to IP1
 ("general SOCKS server failure")
 12.10.2016 12:28:54.800 [NOTICE] new bridge descriptor 'Unnamed' (fresh):
 FP2~NAME2 at IP2
 12.10.2016 12:28:54.800 [NOTICE] I learned some more directory
 information, but not enough to build a circuit: We have no usable
 consensus.
 12.10.2016 12:29:05.000 [NOTICE] I learned some more directory
 information, but not enough to build a circuit: We have no recent usable
 consensus.
 12.10.2016 12:29:35.700 [NOTICE] Closing no-longer-configured Socks
 listener on 127.0.0.1:9150
 12.10.2016 12:29:35.700 [NOTICE] DisableNetwork is set. Tor will not make
 or accept non-control network connections. Shutting down all existing
 connections.
 12.10.2016 12:29:35.700 [NOTICE] Closing old Socks listener on
 127.0.0.1:9150
 12.10.2016 12:29:36.500 [NOTICE] Delaying directory fetches:
 DisableNetwork is set.
 }}}

 Steps to reproduce:
  1. Get some bridges.
  2. Change networks (get a new IP address)
  3. Enter an URL --> time out
  4. Open network settings, point the cursor into the field where bridges
 are set and click on the OK button
  5. Open a new URL or reload the old one --> site will open

 Do you need more information? Should I try to log with debug information?

--
Ticket URL: <https://trac.torproject.org/projects/tor/ticket/20379>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online
_______________________________________________
tor-bugs mailing list
tor-bugs@lists.torproject.org
https://lists.torproject.org/cgi-bin/mailman/listinfo/tor-bugs

Reply via email to