So I think I'll be doing the epoch bump with 4.0 which should help somewhat.
There will still be the issue of not having the binary packages themselves 
lined up (different names) but that should be a step forward.

** Changed in: lxc (Ubuntu)
       Status: New => In Progress

** Changed in: lxc (Ubuntu)
     Assignee: (unassigned) => Stéphane Graber (stgraber)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lxc in Ubuntu.
https://bugs.launchpad.net/bugs/1837537

Title:
  FTBFS since lxc has different version numbers in Debian and Ubuntu

Status in lua-lxc package in Ubuntu:
  Fix Committed
Status in lxc package in Ubuntu:
  In Progress

Bug description:
  The lua-lxc [1] package currently fails to build since it cannot
  satisfy the build dependency: lxc-dev (>= 1:3.0.2-1~exp+1).

  Looks like this is caused by different version numbers in Debian and
  Ubuntu. The latest version in Debian unstable is 1:3.1.0+really3.0.3-8
  while Ubuntu eoan has 3.0.3-0ubuntu1. I believe the 1: epoch (?) is
  causing this issue.

  Presumably lua-lxc needs to be patched to allow the Ubuntu package to
  fulfill the build requirements.

  
  [1] https://bugs.launchpad.net/ubuntu/+source/lua-lxc/1:3.0.2-1
  [2] 
https://bugs.launchpad.net/ubuntu/+source/lua-lxc/1:3.0.2-1/+build/16664061

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/lua-lxc/+bug/1837537/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to