Thanks for reporting.

Have you enabled -proposed by any chance? Please post the output from
`apt policy xkb-data`.

Because the only place I can see version 2.41-2 is in noble-proposed
[1], which also seems part of the reason why it hasn't migrated to the
release repo [2].


** Tags added: noble unmetdeps

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to console-setup in Ubuntu.

  Can't upgrade keyboard-configuration on Noble

Status in console-setup package in Ubuntu:

Bug description:
  I'm testing Noble using multipass and I got this error when I try to upgrade 
the system:
  ubuntu@ubuntu2404:~$ sudo apt full-upgrade
  Reading package lists... Done
  Building dependency tree... Done
  Reading state information... Done
  Calculating upgrade... Error!
  Some packages could not be installed. This may mean that you have
  requested an impossible situation or if you are using the unstable
  distribution that some required packages have not yet been created
  or been moved out of Incoming.
  The following information may help to resolve the situation:

  The following packages have unmet dependencies:
   keyboard-configuration : Depends: xkb-data (< 2.38A) but 2.41-2 is to be 
  E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by 
held packages.

  I think because in the package "Depends" section the configuration is in this 
  Depends: debconf (>= 0.5) | debconf-2.0, liblocale-gettext-perl, xkb-data (>= 
2.38~), xkb-data (<< 2.38A)

  So I think it should be a "|"(pipe) instead of "," (comma) when
  refering to xkb-data.

  The keyboard-configuration package version is 1.223ubuntu1.

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to