>Yes, I have proposed enabled.

I assume you are aware it's not generally recommended to keep proposed
enabled and install all upgrades. Anyways, that means this is the same
issue which is keeping xkeyboard-config from migrating to the release

Regarding comma or pipe, I cannot say for certain because I'm not that
familiar with this package but it might be on purpose. Some packages do
it to lock their dependencies in place. This is especially true if the
underlying package do large changes so you cannot be sure if everything
still works with newer versions or if you need to know what the changes
are to take full advantage of the new things. This means that 2.38.1,
2.38.2 or security fixes will still match and be installable but never
versions like 2.39 would be blocked. Maybe all console-setup needs is a
manual rebuild to pick up the current version available or it might
require further changes to the package to handle the newer changes.

The way forward will probably be a newer version of console-setup which
supports the latest version, when that is uploaded to -proposed both
packages will work and can be migrated together. In the meantime,
xkeyboard-config will be kept in -proposed in order to not make other
packages uninstallable.

** Also affects: xkeyboard-config (Ubuntu)
   Importance: Undecided
       Status: New

** Summary changed:

- Can't upgrade keyboard-configuration on Noble
+ Can't upgrade keyboard-configuration on Noble-proposed

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to console-setup in Ubuntu.

  Can't upgrade keyboard-configuration on Noble-proposed

Status in console-setup package in Ubuntu:
Status in xkeyboard-config package in Ubuntu:

Bug description:
  I'm testing Noble using multipass and I got this error when I try to upgrade 
the system:
  ubuntu@ubuntu2404:~$ sudo apt full-upgrade
  Reading package lists... Done
  Building dependency tree... Done
  Reading state information... Done
  Calculating upgrade... Error!
  Some packages could not be installed. This may mean that you have
  requested an impossible situation or if you are using the unstable
  distribution that some required packages have not yet been created
  or been moved out of Incoming.
  The following information may help to resolve the situation:

  The following packages have unmet dependencies:
   keyboard-configuration : Depends: xkb-data (< 2.38A) but 2.41-2 is to be 
  E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by 
held packages.

  I think because in the package "Depends" section the configuration is in this 
  Depends: debconf (>= 0.5) | debconf-2.0, liblocale-gettext-perl, xkb-data (>= 
2.38~), xkb-data (<< 2.38A)

  So I think it should be a "|"(pipe) instead of "," (comma) when
  refering to xkb-data.

  The keyboard-configuration package version is 1.223ubuntu1.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to