About two years ago I ran into a problem whose solution was so obvious that I did not even write it down after solving it: The Trisquel_7 Live USB that I made back then wanted the selected partition (/dev/sdc1 in the present case) to be mounted at root (/). Today I attempted to re-guess the solution and first tried GParted, but that did not succeed because the "mount" item in the menu was greyed out. I reverted to the Live USB's console and used "sudo mount /dev/sdc1" to create the "/" mount point.

The Live USB would not recognize the "/" mount point even though that's exactly how it looked in the installation GUI, and I could not change that setting, the Live USB saying that there were other devices mounted at the same place. I had to go back to the console and use "sudo umount /dev/sdc1" to get rid of the "/" in the installation GUI for /dev/sdc.


My intention was to install TQ_7 in the first 22GB partition, along with an adjacent small linux_swap partition, followed by a second 20GB partition for TQ_8, another linux swap partition in an extended logical partition, and finally a data partition in the remainder of the extended partition. I formatted all these ahead of time with GParted. There is no actual data on the external hard drive.

Is my solution to start over, let the Live USB repartition and reformat the entire /dev/sdc hard drive, and hope that the "/" difficulty can be overcome with the GParted that is already on the Live USB if it surfaces again ?

George Langford

Reply via email to