Hi Chaoskreator,

I just tried the most simple example of setting up a Tweet box and was able
to get the tweet sent to Twitter.com without issue. I don't see anything
obviously wrong in your HTML. If you've "connected" the user, then I also
assume that your callback URL specified in your application record
corresponds to the subdomain and host of the server using @Anywhere.

What happens when you try the simplest possible example in isolation of
other Javascript? (no widgets, other frameworks, etc.) Determining that will
give you a baseline to determine if it's an interaction with some other
resource on your page in conflict.

Taylor Singletary
Developer Advocate, Twitter
http://twitter.com/episod


On Mon, Apr 19, 2010 at 10:12 PM, chaoskreator <chaoskrea...@gmail.com>wrote:

> Hello. I've been developing a Twitter modification for integration
> with phpBB3. I've registered in Anywhere, set everything up and I'm
> using the following code in the HTML header:
>
> &lt;script src="http://platform.twitter.com/anywhere.js?
> id=xxxxxxxx&v=1" type="text/javascript"&gt;&lt;/script&gt;
>
> And this is the body:
>
> &lt;!-- INCLUDE overall_header.html --&gt;
>
> &lt;div class="panel"&gt;
>        &lt;div class="inner"&gt;&lt;span class="corners-
> top"&gt;&lt;span&gt;&lt;/span&gt;&lt;/span&gt;
>
>                &lt;div style="text-align:center;margin:0 auto;"&gt;
>                        &lt;span
> id="twitter-connect-placeholder"&gt;&lt;/span&gt;
>
>                        &lt;div style="display:inline;"&gt;
>                                &lt;div style="float:left;"&gt;
>                                        &lt;script src="
> http://widgets.twimg.com/j/2/widget.js"&gt;&lt;/
> script&gt;
>                                        &lt;script&gt;
>                                                new TWTR.Widget({
>                                                        version: 2,
>                                                        type: 'profile',
>                                                        rpp: 4,
>                                                        interval: 6000,
>                                                        width: 250,
>                                                        height: 300,
>                                                        theme: {
>                                                                shell: {
>
>  background: '#333333',
>
>  color: '#ffffff'
>                                                                },
>                                                                tweets: {
>
>  background: '#000000',
>
>  color: '#ffffff',
>
>  links: '#4aed05'
>                                                                }
>                                                        },
>                                                        features: {
>                                                                scrollbar:
> true,
>                                                                loop: false,
>                                                                live: true,
>                                                                hashtags:
> true,
>                                                                timestamp:
> true,
>                                                                avatars:
> true,
>                                                                behavior:
> 'all'
>                                                        }
>
>  }).render().setUser('{TWIT_USR}').start();
>                                        &lt;/script&gt;
>                                &lt;/div&gt;
>
>                                &lt;div style="float:right;"&gt;
>                                        &lt;div id="tbox"&gt;&lt;/div&gt;
>
>                                        &lt;script
> type="text/javascript"&gt;
>                                                twttr.anywhere(function (T)
> {
>
>  T("#tbox").tweetBox({
>                                                                height: 100,
>                                                                width: 400,
>
>  defaultContent: "Your tweet here..."
>                                                        });
>
>                                                        var currentUser,
>                                                                screenName,
>
>  profileImage,
>
>  profileImageTag;
>
>                                                        if (T.isConnected())
> {
>                                                                currentUser
> = T.currentUser;
>                                                                screenName =
> currentUser.data('screen_name');
>                                                                profileImage
> = currentUser.data('profile_image_url');
>
>  profileImageTag = "&lt;img src='" + profileImage + "'/&gt;";
>
>  $('#twitter-connect-placeholder').append("Logged in as " +
> profileImageTag + " " + screenName);
>                                                         } else {
>
>  T("#twitter-connect-placeholder").connectButton();
>                                                         };
>                                                });
>                                        &lt;/script&gt;
>
>                                &lt;/div&gt;
>                        &lt;/div&gt;
>                &lt;/div&gt;
>
>        &lt;span class="corners-bottom"&gt;&lt;span&gt;&lt;/span&gt;&lt;/
> span&gt;&lt;/div&gt;
> &lt;/div&gt;
>
> &lt;!-- INCLUDE overall_footer.html --&gt;
>
> However, neither the twitter-connect-placeholder span, nor the tbox
> div seem to be working correctly.
> twitter-connect-placeholder is supposed to display the connect button
> if the user is not logged in, and is supposed to display the user's
> pic and user name if they're logged in. It doesn't doesn't seem do
> display anything at all, though.
> tbox displays the tweetbox correctly, but when I actually try to tweet
> something, it never seems to make it to the twitter account. The
> browser accesses api.twitter.com, seems to submit correctly, but the
> tweet never shows up.
>
> FireBug shows that I am authenticated, and I've verified the existence
> of all the necessary data.
>
> Any idea what might be the issue?
>
>
> --
> Subscription settings:
> http://groups.google.com/group/twitter-development-talk/subscribe?hl=en
>

Reply via email to