I've tried discussing with the author of twaud.io, but he says he
doesn't really have time to look.  I've tried sending even a minimal
test iPhone app Xcode project to twitter api support, but a week later
no response.

Our app is xAuth authorized, the app sends the username and password
and gets a token, we produce all the intended headers and post up to
twaud.io's api as described at twaud.io/api and yet just get the below
totally opaque response:

response: HTTP/1.1 403 Forbidden / Not Authorized

Made sure that the twitter account I used for testing has given both
our app and twaud.io read/write authorization.

Here's a sample of what I am putting in "X-Verify-Credentials-
Authorization" (which we've tried naming that way and also, per the
twaud.io api page, "x_verify_credentials_authorization").  We've also
tried sending the value as either post values or as a request header:

OAuth realm="http%3A%2F%2Fapi.twitter.com",

I would be more than happy to send a minimal Xcode project to anyone
who is willing to try running it in the iOS simulator.

Twitter developer documentation and resources: http://dev.twitter.com/doc
API updates via Twitter: http://twitter.com/twitterapi
Issues/Enhancements Tracker: http://code.google.com/p/twitter-api/issues/list
Change your membership to this group: 

Reply via email to