The error does not occur when launching the two listening sockets. It is 
during a HTTP client stress test from,

Socrates Web Tester ---> Load Balancer ---> Web Server

after a few hundred normal requests, the load balancer's HTTP connection to 
the web server returns 10048 error. So it is not the listening socket giving 
the 10048, it is the client socket.

Regards,

SZ

----- Original Message ----- 
From: "Francois PIETTE" <[EMAIL PROTECTED]>
To: "ICS support mailing" <twsocket@elists.org>
Sent: Monday, December 26, 2005 9:49 PM
Subject: Re: [twsocket] Two ICS HTTP code against each other and 10048 error


>> There are thousands of sockets listen in TCPView!
>> How can I understand which one I should be looking for?
>
> Why is there thousands of listening sockets ? Are you opening so much
> sockets ? If you don't know, that may be you have a bug.
>
> --
> [EMAIL PROTECTED]
> http://www.overbyte.be
>
>
> ----- Original Message ----- 
> From: "Fastream Technologies" <[EMAIL PROTECTED]>
> To: "ICS support mailing" <twsocket@elists.org>
> Sent: Monday, December 26, 2005 8:47 PM
> Subject: Re: [twsocket] Two ICS HTTP code against each other and 10048 
> error
>
>
>> There are thousands of sockets listen in TCPView! How can I understand
>> which
>> one I should be looking for?
>>
>> Best Regards,
>>
>> SZ
>>
>> ----- Original Message ----- 
>> From: "Francois PIETTE" <[EMAIL PROTECTED]>
>> To: "ICS support mailing" <twsocket@elists.org>
>> Sent: Sunday, December 25, 2005 10:03 PM
>> Subject: Re: [twsocket] Two ICS HTTP code against each other and 10048
>> error
>>
>>
>>>> Could it be that the socket tuples of two ICS code share the same port
>>>> number somehow?
>>>
>>> At least two sockets in the system.
>>> Use netstat when it occurs to see if this is the case.
>>> --
>>> [EMAIL PROTECTED]
>>> http://www.overbyte.be
>>>
>>>
>>> ----- Original Message ----- 
>>> From: "Fastream Technologies" <[EMAIL PROTECTED]>
>>> To: "ICS support mailing" <twsocket@elists.org>
>>> Sent: Sunday, December 25, 2005 6:47 PM
>>> Subject: [twsocket] Two ICS HTTP code against each other and 10048 error
>>>
>>>
>>>> Hello,
>>>>
>>>> When I run my ICS load balancer against Apache with Socrates, 
>>>> everything
>>>> is fine. When I run Socrates directly against my ICS web server, still
>>>> fine. But when I use:
>>>>
>>>> Socrates ---> ICS load balancer ---> ICS web server
>>>>
>>>> I get the following in every 600-700 connections:
>>>>
>>>>      WSAEADDRINUSE
>>>>      (10048) Address already in use.
>>>>        An application attempts to bind a socket to an IP address/port
>>>> that
>>>> has already been used for an existing socket
>>>>
>>>>
>>>> Could it be that the socket tuples of two ICS code share the same port
>>>> number somehow?
>>>>
>>>> Best Regards,
>>>>
>>>> SZ
>>>> -- 
>>>> To unsubscribe or change your settings for TWSocket mailing list
>>>> please goto http://www.elists.org/mailman/listinfo/twsocket
>>>> Visit our website at http://www.overbyte.be
>>>
>>> -- 
>>> To unsubscribe or change your settings for TWSocket mailing list
>>> please goto http://www.elists.org/mailman/listinfo/twsocket
>>> Visit our website at http://www.overbyte.be
>>
>> -- 
>> To unsubscribe or change your settings for TWSocket mailing list
>> please goto http://www.elists.org/mailman/listinfo/twsocket
>> Visit our website at http://www.overbyte.be
>
> -- 
> To unsubscribe or change your settings for TWSocket mailing list
> please goto http://www.elists.org/mailman/listinfo/twsocket
> Visit our website at http://www.overbyte.be 

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to