the 404 is correct, IE will also get the 404. But ebay has changed the 
layout of the 404 error page to load some other pages
like  //snip from 404 page// cfg.sModuleUrl 
='http://promo.ebay.com/ws/eBayISAPI.dll?GetPPModules&usecase=2' ;  \\\\\

so you must read the 404 page and then execute the code in that page :-)

----- Original Message ----- 
From: "Borosnyay Péter" <[EMAIL PROTECTED]>
To: "ICS support mailing" <twsocket@elists.org>
Sent: Monday, June 12, 2006 9:02 AM
Subject: Re: [twsocket] THTTPCli & "false" 404 pages


> Hi !
>
> Opera also gets the fancy page, so it's probably not IE-related.
>
> Cheers, Peter
>
> On Mon, 12 Jun 2006 03:37:34 +0200, <[EMAIL PROTECTED]> 
> wrote:
>>
>>
>> Please offer suggestion for this circumstance -->
>>
>> If I use httpcli to get this page:
>>
>> http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=6286283929
>>
>> everything is perfect.
>>
>> If I try to get non existent auction at same site with INTERNET EXPLORER 
>> for
>> example:
>> http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=notauctionnumber
>> is the non existent auction URL.
>>
>> Then a fancy page appears saying item does not exist.
>>
>>
>> WITH HTTPCLI, it gets a 404 error.  I have guesses that the ISAPI.dll 
>> sends
>> back the fancy -page to IE or that it is something else.
>>
>> Is there any way to get same page as IE?  What am I doing wrong for this
>> circumstance with nonexistent auction number?
>>
>>
>> -------------------------------------------------
>> This mail sent through IMP: http://horde.org/imp/
>
>
>
> -- 
> FIGYELEM !  Ennek a levélnek a végén NINCS REKLÁM !!!
> észrevetted ?
>
> -- 
> To unsubscribe or change your settings for TWSocket mailing list
> please goto http://www.elists.org/mailman/listinfo/twsocket
> Visit our website at http://www.overbyte.be 

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to