Hi all! 

It's been years since I posted on the list! Yep, I have come across a
problem ;) This is a weird one; I hope some of the gurus here can help. And
I do apologize for the length of this message!

Over the years I received a few reports from users using my newsreader
reporting that while downloading certain posts the download would suddenly
stop. No crash, just nothing happening anymore.

These reports have been rare but a couple date back to as early as 2000. I
initially attributed them to a bad connection or to a glitch of some kind on
the user machine, but a user wrote last week with this same problem again.

After a bit of investigating (and arm twisting!), I was able to get the
MessageID to one of the post that caused the newsreader to stop. To my
surprise, my newsreader *does* stop on that post on my very own computer!

I decided to try and find the cause of this and I downloaded the latest
version of ICS from Francois' site to investigate. Guess what? The post also
causes the demo Newsreader in the ICS distribution to stop! So the problem
is not my app after all.

I then tried the demo newsreader on three other computers on my network and
none of them had any problems downloading the post to completion on numerous
tries. Only my computer seems to be affected.

Next, I tried to download that same post using Outlook Express on my
computer. I'm pretty puzzled because it had no problem downloading it.

Going on, I tried this: downloading the post using BodyByID instead of
ArticleByID in the demo newsreader and it worked! I can repeat this behavior
at will, using ArticleByID it doesn't complete, and using BodyByID the posts
get completely downloaded.

With ArticleByID the demo newsreader stops at exactly the same place each
time, the last line received is #1975 or a message having 1985 lines. The
last 10 lines never come in using ArticleByID.

I'm pretty much stuck here at the moment, because I have no idea on how to
proceed with my investigation. While I know the Nntp component very well
(having rewritten several part of it), the inner workings of the WSocket
component are a mystery to me. I have no idea what FD_READ and all the other
stuff stand for :(

Still, it does sound as if the last packet (in case of network problem) or
buffer (in case of WSocket/NntpCli problem) never come in and the nntp
component keep waiting. In fact, if I try to send the Quit command an
exception is raised because the state is not nntpReady.

Can anyone offer any help or suggestion? I've been at this non-stop since
last week and I can't think of anything else to do...

Many thanks...

Eric Fortier

PS: If anyone wants to check out the message, the MessageID is:
<[EMAIL PROTECTED]>. I apologize for the content (warez
newsgroup) but I have nothing else to work with.

PPS: I have no antivirus, firewall or antispyware installed on my machine
and I also tried to connect on many different ports to my news server

To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to