<< My ClientDataAvailable() procedure (assigned to my TWSocketServer's
OnDataAvailable() event as shown below) is firing twice--for every message I
send my app from my test utility, ClientDataAvailable() gets fired twice!>>

I notice in the Debug Window (BDS 2006) that the following are called, one
right after the other:

WSocket.TCustomLineWSocket.TriggerDataAvailable(0)
WSocket.TCustomSocksWSocket.TriggerDataAvailable(0)
WSocket.TCustomWSocket.TriggerDataAvailable(0)

Is this why my ClientDataAvailable() is called multiple times?

BTW, what is the netiquette regarding mailing lists as to snipping previous
parts of the thread--should I cut out everything below this, or leave it be
(leaving it be until I hear/read otherwise).

-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On
Behalf Of Clay Shannon
Sent: Wednesday, November 22, 2006 10:28 AM
To: 'ICS support mailing'
Subject: Re: [twsocket] Still "rassling" with sending and receiving

Right now, though, it's working TOO good <g>

My ClientDataAvailable() procedure (assigned to my TWSocketServer's
OnDataAvailable() event as shown below) is firing twice--for every message I
send my app from my test utility, ClientDataAvailable() gets fired twice!

procedure TfClientMain.WSocketServerClientConnect(Sender: TObject; Client:
TWSocketClient; Error: Word);
begin
  if Error <> 0 then begin
    ClientDM.InsertException(CurrentUser, IntToStr(Error),
SocksErrorCodeToStr(Error));
    Exit;
  end;
  ClientDM.InsertEventLog(
    SOCKET_EVENT, 'WSocketServerClientConnect', Now, CurrentUser,
GetMachineName);
  with Client as TTcpSrvClient do begin
    LineMode            := TRUE; //False in .DFM
    LineEdit            := TRUE;
    LineLimit           := 255; //Do not accept long lines - changed from 80
    OnDataAvailable     := ClientDataAvailable;
    OnLineLimitExceeded := ClientLineLimitExceeded;
    OnBgException       := ClientBgException;
    ConnectTime         := Now;
  end;
end;

-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED] On
Behalf Of Wilfried Mestdagh
Sent: Tuesday, November 21, 2006 1:37 PM
To: ICS support mailing
Subject: Re: [twsocket] Still "rassling" with sending and receiving

Hello Clay,

> OK, by going over the clidemo and TCPServ projects (which successfully
> communicate with each other) with a fine-toothed comb, and setting all my
> design-time and run-time properties, etc., as in those demos, I was able
to
> get it to work.

Good :)
   
---
Rgds, Wilfried [TeamICS]
http://www.overbyte.be/eng/overbyte/teamics.html
http://www.mestdagh.biz

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be


The information transmitted is intended only for the person or entity to
which it is addressed and may contain confidential and/or privileged
material.  If the reader of this message is not the intended recipient,
you are hereby notified that your access is unauthorized, and any review,
dissemination, distribution or copying of this message including any
attachments is strictly prohibited.   If you are not the intended
recipient, please contact the sender and delete the material from any
computer.
-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to