Anyone has any idea on this?

Best regars,

Marcelo Grossi

----- Original Message ----- 
From: "Marcelo Grossi" <[EMAIL PROTECTED]>
To: <twsocket@elists.org>
Sent: Friday, December 01, 2006 10:20 AM
Subject: [twsocket] Acess Violation - TCustomWSocket


> Hello everyone,
>
> There is this weird AE happening when I free my TWSocket... I managed to 
> debug it up to the point below:
>
> TWSocket.pas
> *****************
> Line 3516
> *****************
>        Dec(WSocketGCount);
>        if WSocketGCount <= 0 then begin
>            WSocketUnloadWinsock;                            // <---- AE 
> happens here
> {           WSocketGCount := 0;  // it is set to 0 in 
> WSocketUnloadWinsock }
>        end;
>
> *****************
> Line 1798
> *****************
> function WSocket_Synchronized_WSACleanup : Integer;
> begin
>    if @FWSACleanup = nil then
>        @FWSACleanup := WSocketGetProc('WSACleanup');
>    Result := FWSACleanup; // <--- AE happens right after this ....
> end;
>
>
> I don't know what I did wrong for this AE to be thrown. I can't even catch 
> the exception. This happens all the time on my machine but on most 
> machines using my app this problem never occurs...
> I cannot give you more details on the architecture of my app right, but 
> any help on this matter will be greatly apreciated.
>
> Thanks,
>
> Marcelo Grossi
> -- 
> To unsubscribe or change your settings for TWSocket mailing list
> please goto http://www.elists.org/mailman/listinfo/twsocket
> Visit our website at http://www.overbyte.be
> 

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to