> > I took the SSLFTPCli demo application and set
> > everything up.
> > 
> > However, everything works but the client gets no
> > responses when I do a LIST or STOR. 
> > 
> > WS_FTP Pro works perfectly, straight out of the box
> > when I set the Trusted sites.
> It probably uses passive mode or knows the public IP
> address?

> > 
> > Any ideas as to why this may be happening?
> The problem with active mode and SSL is that the router can
> not exchange the local IP address of the port command with 
> the public IP as long as the control connection is 
> encrypted. I think there could be added a property to the 
> TFtpCli which sets the public IP to use.
> Have you tried passive mode yet?

OK, I've tried setting Passive to True explicitly and it 
still doesn't work. Besides, the LIST command sets to PASV 

I've tried both the SslFtpCliTest and the SslFtpTst projects
and they both exhibit the same behavior.

I'm at a loss as to what to try next. It CANNOT be a firewall 
because WS_FTP Pro works just fine.

To unsubscribe or change your settings for TWSocket mailing list
please goto http://lists.elists.org/cgi-bin/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to