Sorry, I accidentally pressed send button before the mail was done.

I use FTP client demo from OverbyteIcsSslFtpTst1.dpr. I set up server,
port, username, password, host file (directory on server). Then I use
these commands:

Open - ok
Auth TLS/SSL - ok
User - ok
Pass - ok
Cwd - ok
Pwd - ok (I see directory where I was supposed to be)
Dir - timeout

So everything works except dir command always fails on timeout. Any idea?
The server is not mine so I cant give you testing login :(


Here is output:

Winsock version 2.2
WinSock 2.0
Running
Executing Requested Command
< 220 EFT Server 6.2.1 Build 03.04.2010.1
Session Connected, error = 0
Request 1 Done.
StatusCode = 220
LastResponse was : '220 EFT Server 6.2.1 Build 03.04.2010.1'
No error
Command Success
Executing Requested Command
> AUTH SSL
< 234 AUTH Command OK. Initializing SSL connection.
! SSL handshake OK
Request 48 Done.
StatusCode = 234
LastResponse was : '234 AUTH Command OK. Initializing SSL connection.'
No error
Command Success
Executing Requested Command
> USER ***
< 331 Password required for ***.
Request 2 Done.
StatusCode = 331
LastResponse was : '331 Password required for ***.'
No error
Command Success
Executing Requested Command
> PASS ********
< 230 Login OK. Proceed.
Request 3 Done.
StatusCode = 230
LastResponse was : '230 Login OK. Proceed.'
No error
Command Success
Executing Requested Command
> PASV
< 227 Entering Passive Mode (10,197,200,134,109,96).
> LIST
< 150 Opening ASCII mode data connection for file list.
Session Closed, error = 0
Command Failure
Request 7 Done.
StatusCode = 426
LastResponse was : '150 Opening ASCII mode data connection for file list.'
Error = 426 (426 Timeout)
--
To unsubscribe or change your settings for TWSocket mailing list
please goto http://lists.elists.org/cgi-bin/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to