On Thu, 1 Mar 2018 13:55:19 -0600 Mariano Coromac wrote:
> I found the problem. In my header file I was reading from eMMC device 1.
> Not 0. That's why the operations with mmc worked in command line but did
> not on startup.
> Please correct me if I'm mistaken but I have a couple questions.
> 1) Do I need a partition in my eMMC in order to boot the Linux kernel?
> When I run "mmc part" it shows no partition at all.
> 2) When U-Boot finishes compiling it generates a .dtb with the name of my
> custom board. I need to write this file (alongside zImage) inside my eMMC
> for my Linux Kernel to boot right?
> When I try to boot the kernel it hangs in here:
> => boot
> reading p_a5_tab_reva.dtb
> 13699 bytes read in 18 ms (743.2 KiB/s)
> reading zImage
> 3749624 bytes read in 298 ms (12 MiB/s)
> ## Flattened Device Tree blob at 21000000
>    Booting using the fdt blob at 0x21000000
>    Loading Device Tree to 27b7d000, end 27b83582 ... OK
> Starting kernel ...
> What do you think of this? Perhaps is regarding the kernel itself or maybe
> is a UBoot configuration?
My guess is that the fdt is out of reach for the kernel.
Try setting the fdt_high variable to limit the range where U-Boot will
copy the fdt.
fdt_high=ffffffff will prevent copying the fdt at all, other values
specify the upper limit for the memory address where the fdt will end
after copying.

Lothar Waßmann
U-Boot mailing list

Reply via email to