On Wed, Apr 04, 2018 at 08:51:16AM +0000, Alexey Brodkin wrote:
> Hi Tom,
> 
> On Tue, 2018-04-03 at 16:49 -0400, Tom Rini wrote:
> > On Tue, Apr 03, 2018 at 08:27:20PM +0000, Alexey Brodkin wrote:
> > > Hi Tom,
> > > 
> > > On Tue, 2018-04-03 at 16:25 -0400, Tom Rini wrote:
> > > > On Tue, Apr 03, 2018 at 08:21:06PM +0000, Alexey Brodkin wrote:
> > > > > Hi Tom,
> > > > > 
> > > > > On Tue, 2018-04-03 at 16:17 -0400, Tom Rini wrote:
> > > > > > On Mon, Apr 02, 2018 at 12:18:02PM +0300, Alexey Brodkin wrote:
> > > > > > 
> > > > > > > With the most recent tools for ARC (arc-2017.09) in case of
> > > > > > > "naked" function compiler throws a warning:
> > > > > > > ---------------------------------->8-----------------------------
> > > > > > > board/synopsys/hsdk/hsdk.c: In function 'hsdk_core_init_f':
> > > > > > > board/synopsys/hsdk/hsdk.c:345:1: warning: stack usage 
> > > > > > > computation not supported for this target
> > > > > > >  }
> > > > > > >  ^
> > > > > > > ---------------------------------->8-----------------------------
> > > > > > > 
> > > > > > > That happens because the compiler doesn't handle "naked" functions
> > > > > > > as a special case where stack calculation shouldn't be done.
> > > > > > > 
> > > > > > > But for now until this is fixed in GCC to get clean buildman 
> > > > > > > output
> > > > > > > we're disabling stack-usage check for ARC.
> > > > > > > 
> > > > > > > See https://lists.denx.de/pipermail/u-boot/2018-April/324455.html
> > > > > > > for more background.
> > > > > > > 
> > > > > > > Signed-off-by: Alexey Brodkin <abrod...@synopsys.com>
> > > > > > > Cc: Masahiro Yamada <yamada.masah...@socionext.com>
> > > > > > > Cc: Tom Rini <tr...@konsulko.com>
> > > > > > 
> > > > > > Erm, this patch isn't working for me.  I take the current ARC PR, 
> > > > > > and
> > > > > > apply this, and I still see the warning showing up.
> > > > > 
> > > > > How do you see an issue?
> > > > > Could you please make sure arc-2017.09 tools are used but not 
> > > > > arc-2016.09?
> > > > > See my change for TravisCI in the same PR.
> > > > 
> > > > ... but the patch here is disabling -fstack-usage altogether for ARC,
> > > > yes?
> > > 
> > > Right, but that's a temporary "patch" for the problem in hand.
> > > Once GCC 8.x gets released we'll just switch to it and that problem 
> > > shouldn't
> > > bother us any longer.
> > 
> > OK.  But this patch doesn't work and we're trying -fstack-usage is the
> > problem I see :)
> 
> Well probably I'm missing something :)
> 
> Here's a TravisCI job for ARC that passes perfectly fine:
> https://travis-ci.org/abrodkin/u-boot/jobs/362026822
> 
> Stuff that is built there is here:
> https://github.com/abrodkin/u-boot/commits/staging-arc

Yes, OK, moving to 2017.09 also is fine here, so I'm just going to
accept it and move on.  Thanks!

-- 
Tom

Attachment: signature.asc
Description: PGP signature

_______________________________________________
U-Boot mailing list
U-Boot@lists.denx.de
https://lists.denx.de/listinfo/u-boot

Reply via email to