Fix inconsistent parameter naming of the hash algorithm.

Signed-off-by: Chia-Wei Wang <chiawei_w...@aspeedtech.com>
Fixes: 92055e138f2 ("image: Drop if/elseif hash selection in calculate_hash()")
---
 common/image-fit.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/common/image-fit.c b/common/image-fit.c
index 5a0a0cc200..a53a2b5d6f 100644
--- a/common/image-fit.c
+++ b/common/image-fit.c
@@ -1201,7 +1201,7 @@ int fit_set_timestamp(void *fit, int noffset, time_t 
timestamp)
  * calculate_hash - calculate and return hash for provided input data
  * @data: pointer to the input data
  * @data_len: data length
- * @algo: requested hash algorithm
+ * @name: requested hash algorithm name
  * @value: pointer to the char, will hold hash value data (caller must
  * allocate enough free space)
  * value_len: length of the calculated hash
@@ -1229,7 +1229,7 @@ int calculate_hash(const void *data, int data_len, const 
char *name,
                return -1;
        }
 
-       hash_algo = hash_algo_lookup_by_name(algo);
+       hash_algo = hash_algo_lookup_by_name(name);
        if (hash_algo == HASH_ALGO_INVALID) {
                debug("Unsupported hash algorithm\n");
                return -1;
-- 
2.17.1

Reply via email to