Hi Simon,

On Sat, Sep 19, 2026 at 4:43 AM Simon Glass <[email protected]> wrote:
>
> Hi Aristo,
>
> On 2026-09-12T12:44:46, Aristo Chen <[email protected]> wrote:
>
> > The 'Shared image data' section of the Flat Image Tree specification [1]
> > defines an image-data property [...]
>
> Thanks for the thorough cover letter and the hardware numbers. Also
> for taking this on while I am on a patch holiday :-)
>
> Please add user-facing documentation under doc/usage/fit/ describing
> image-data. A short section (either in multi.rst, since this lands
> most naturally in multi-configuration FITs, or a new file) covering
> what the property means, the resolved form mkimage produces, the
> encrypted-sharing rules and a pointer to the external spec. Right now
> someone trying to shrink a multi-board FIT has no way to discover this
> from the U-Boot docs.
>
> Also we have example files and this feels like a case where a new
> example would help - see doc/usage/fit/

I will fix this in v2

>
> Just to check - patch 4 is closing a validation gap opened by patch 2
> rather than fixing a pre-existing bug, since data-less images did not
> exist before image-data was introduced. Would folding it into patch 2
> make things easier to follow? Either way is fine.

That is the right reading. I kept it separate mainly for review size:
the resolve patch is already the largest change in the series, at 360
added lines, while this is a 45-line edit to a different function, the
region collection in fit_import_data(), with its own reasoning. A
small follow-on patch seemed easier to follow than growing the big one
further. In v2, I will update the commit message to explicitly state that it
completes the validation for the new property rather than fixing a
pre-existing problem. If you would still rather see it folded into the
resolve patch for v2, that is easy to do.

Thanks for the review and for the patch-holiday exception! I will also fix
other concerns you pointed out for patch 2.

>
> Regards,
> Simon

Best regards,
Aristo

Reply via email to