On 10/3/26 04:08, Yixun Lan wrote:
> Hi E Shattow, 
> 
> On 03:02 Sat 03 Oct     , E Shattow wrote:
>> Hi Yixun,
>>
> ..
>>> diff --git a/board/spacemit/k3/Kconfig b/board/spacemit/k3/Kconfig
>>> new file mode 100644
>>> index 00000000000..1a63c73b6bb
>>> --- /dev/null
>>> +++ b/board/spacemit/k3/Kconfig
>>> @@ -0,0 +1,30 @@
>>> +# SPDX-License-Identifier: GPL-2.0-or-later
>>> +#
>>> +# Copyright (C) 2026 Yixun Lan <[email protected]>
>>> +
>>> +if TARGET_SPACEMIT_K3
>>> +
>>
>>> +config SYS_BOARD
>>> +   default "k3"
>>
>> Let's arbitrarily change user-facing SYS_BOARD to "spacemit_k3" stem of
>> u-boot config filename "spacemit_k3_defconfig":
>>
>> +config SYS_BOARD
>> -    default "k3"
>> +    default "spacemit_k3"
>>
>> The use of SYS_BOARD is compiled-in as various runtime outputs e.g.
>> SMBIOS data structure. 
> Could you iterate a bit more on this? I've not seen K3 used SMBIOS or will
> 

Disregard, I got this detail wrong.


>> I think "spacemit_k3" is not a very interesting
>> or descriptive name to communicate all the boards that may be supported,
>> but it is better for a user to see this defconfig filename stem than
>> simply "k3" as the board name. I do not have any better suggestion
>> because it is a compile-time substitution and board selection is likely
>> to be at runtime.
>>
> I incline to simply keep it as "k3", I've checked all places refer to 
> SYS_BOARD
> which all will be used under SYS_VENDOR realm or somehow has connection with 
> it,
> so there should be no conflicts, to me, it's kind of redudant to change to
> 'spacemit_k3', for reference to arch/Kconfig
> 
> config SYS_BOARD
>         string
>         help
>           This option should contain the name of the target board.
>           If it is set, either board/<CONFIG_SYS_VENDOR>/<CONFIG_SYS_BOARD>
>           or board/<CONFIG_SYS_BOARD> directory is compiled depending on
>           whether CONFIG_SYS_VENDOR is set or not.
> 
>           This is optional.  For those targets without the board directory,
>           leave this option empty.
> 
> 
> On the other hand, I do not see SYS_BOARD should strictly follow
> the name of defconfig, various board did so
> 
> some other source code I checked
> 

Yes, keep SYS_BOARD as "k3" is fine. I forgot then that it will affect
the build in this way and that is not any benefit worth changing the
path and everything u-boot build system is looking for. I wish there is
a better name for it than the SoC on a build target that is not just any
one board name, but what we have is not any problem itself.

> cmd/pxe.c:20:   "default-" CONFIG_SYS_ARCH "-" CONFIG_SYS_SOC "-" 
> CONFIG_SYS_BOARD,
> config.mk:29:BOARD := $(CONFIG_SYS_BOARD:"%"=%)
> env/Kconfig:20:   the file board/<vendor>/<board>/<SYS_BOARD>.env exists. 
> Otherwise the
> include/env_default.h:93:#ifdef CONFIG_SYS_BOARD
> tools/buildman/boards.py:194:        'board' : 'SYS_BOARD',
> 
>>> +
>>> +config SYS_VENDOR
>>> +   default "spacemit"
>>> +
> 

Keep R-by tag, no changes requested to SYS_BOARD, thanks!

-E

Reply via email to