Hi all,

I have encountered a similar error when attempting to resize a dynamic file on our system. We are running UV 10.0.15 on W2K3 and when, as Administrator with Full Control, I try to RESIZE {filename} * * * a dynamic file I get this message both on screen and in the Application event log: error 1004....

"UniVerse error: Unhandled Exception raised at address 0x00405CF7 : Access
violation.  Attempted to read from address 0x10309044.  Binary data is
processor CONTEXT structure.. "

I suspect that these events are related as I believe RESIZE attempts to "logto" the account you are in and create a temp file. I have tried different accounts, files and server setups. I have adjusted permissions and programs, to no avail.

Any help would be appreciated as I have run out of ideas.


Andrew Mack
Systems Admin
New Zealand Defence Force

ph 64 4 2371 914
cell 64 021 626 446

From: Sara Burns <[EMAIL PROTECTED]>
Reply-To: U2 Users Discussion List <[EMAIL PROTECTED]>
Subject: UV Crash on W2K3
Date: Fri, 16 Apr 2004 12:02:37 +1200

We are starting testing our application on W2K3 and getting unexplained
problems.  It is proving difficult to isolate the exact cause but we are
starting to see some trends.  The result is the session crashing with the
following general message in the Event Log

Universe error; Unhandled exception raised at address 0x77bd4528
Access violation Attempted to read from address 0x000000d8
Binary data is processor CONTEXT structure

Sometimes the address to be read is 0x00000000

So far we have found that it is very much less likely to occur if we do a
LOGTO DEV rather than logging on directly to DEV.

Can anyone help with information about the difference between a direct login
and a LOGTO which may have some bearing on this.

This situation does appear to be associated with running programs from PROC
and may be influenced by the size of the program.  We ran a very simple 3
line PROC and 3 line program all night without a failure.

The general mechanism used as the framework for our application involves
launching programs via PROC and using PROCREAD and PROCWRITE to pass data.

This is an example of the LAYER.STACK

There are currently 1 uniVerse sessions; 1 interactive, 0 phantom

  Pid..  User name......  Port name.....  Last command

252 ned <telnet:252> telnet:252 runt [ get.input @
0x2F4 ]

Layer type....... Program name.................... Address...

BASIC run machine get.input 0x000002F4

BASIC run machine MAINTLNK 0x00004160

BASIC run machine runt 0x00000B06





Command Language


BASIC run machine CALL.ALL.FUNCTION 0x000000DC





Command Language

Running only basic programs, outside this framework, does not appear to
cause a problem.

We have not managed to get any useful information from DrWatson as this does
not seem to work for a service.
Can anyone give hints as to how to get better information for a UniVerse
session which crashes so we can pass this to IBM. We tried chaning the
MALLOCTRACING flag to 1 but cannot find any output.

We also see at times the @ACCOUNT = 0, @LOGNAME = 0 and @PATH = 00  These
have changed from the original normal values.

We have set up a completely isolated network for W2K3 so everything must be
moved to these machines the old way - floppy disk or CD-ROM. Our network
consists of a W2K3 PDC, a W2K3 member server with UniVerse 10.1 and a XP-Pro
client. All are running on Compaq desktops 1.8GHz, 248Mb RAM

Initially we tried the Personal Edition 10.0.10 on a W2K3 PDC.
We then received the 10.1 version from IBM and tried on the W2K3 PDC
Finally we tried the 10.1 version on a W2K3 member server.

All gave the same results.

I am also posting this on the U2UG so I can view any replies over the
weekend as it is now Friday midday.

Sara Burns

Sara Burns (SEB)
Development Team Leader

Public Trust
Phone: +64 (04) 474-3841 (DDI)

Mobile: 027 457 5974

Information contained in this communication is confidential. If you are not
the intended recipient the information should not be used, disclosed, copied
or commercialised. The information is not necessarily the views nor the
official communication of Public Trust. No guarantee or representation is
made that the communication is free of errors, virus or interference.

-- u2-users mailing list [EMAIL PROTECTED] http://www.oliver.com/mailman/listinfo/u2-users

Listen to music online with the Xtra Broadband Channel http://xtra.co.nz/broadband

u2-users mailing list

Reply via email to