Problem solved for Asus A6Rp laptop --FIRMWARE UPGRADE REQUIRED --

Following other successful stories (see above) regarding firmware
upgrades on a number of laptops I decided to attempt a firmware upgrade
myself. The Asus A6Rp has a TSSTcorpCD/DVD TS-L632D optical drive which
came with firmware version AS05. Asus appears to provide no drive
firmware upgrade - so cross-flashing is required. But first, some

TSST stands for "Toshiba Samsung Storage Technology". Samsung provides these 
drives in their own laptops but they also provide them to other laptop 
companies such as Asus, Acer, HP and others. If you have a Samsung laptop your 
firmware version will likely begin with SC (however other possibilities exist). 
I have an ASUS so the firmware has been labeled ASxx. More on this if you goto and then FIRMWARE->Check F/W VERSION. Samsung appears 
to provide a customised firmware product to other laptop companies. However, 
Samsung only supports their drives in their laptops. Other laptop companies 
must pass on firmware upgrades independently, which in the case of ASUS doesn't 
appear to be happening. Some other laptop companies may do this- you'll have to 

A quick web search shows that these drives are causing trouble for
numerous OS platforms including MSwindows (although the problem
manifests itself a little differently on MSWindows). I'll assert at this
point that I think this bug is not an Ubuntu bug nor is it a Linux
kernel bug: it is a manufacturer firmware bug. However, having said
that, I am very grateful that this did exist as a bug in Ubuntu's
Launchpad because world-wide, Launchpad has been the best source of
information about this problem with some excellent discussion and ideas.

For me the only solution available was to cross-flash with SCxx firmware
to replace my buggy AS05 firmware and hope that the differences between
the custom AS05 and SCxx are negligible. It seems that in the case of
the A6Rp the differences are indeed negligible or perhaps non-existent.

You can check your drive and firmware version in Ubuntu by going:
System>Preferences>Hardware Information ; Now look for your drive. Under
the "advanced" tab you will find > 'info.product' & also
'storage.product' which will say something like "TSSTcorpCD/DVD TS-
L632D" ; and, 'storage.firmware_version' which may say "AS05".
Alternatively, you can download "WININQUIRY.EXE" from and then FIRMWARE>Check F/W VERSION and run
this in MSWindows or run it in Ubuntu using wine (It works perfectly
with wine in Ubuntu feisty).

Note that some laptops that have Samsung drives which are not model TS-
L632D are reported to have been successfully flashed with the SCxx
firmware for the TS-L632D drive (see Andreas on 2007-08-04 above in this
bug commentary).

Below I outline my solution and I also provide reference to a solution
if you don't have an MSwindows partition.

Solution for A6Rp - if you have a bootable MSwindows partition:

You will need the firmware upgrade from Samsung. There are two firmware
upgrade versions available SC03 (dated 2007-02-08) & SC04 (dated
2007-06-12). I used SC03, it solved the problems so I stopped there.
Others have used SC04 without problem, but I can't vouch for SC04 on
Asus A6Rp. Get these firmwares from Samsung at the following addresses:



Or, simply do a search in google for "TS-L632D_SC03.EXE" or "TS-
L632D_SC04.EXE" and you will find them. The first thing you will notice
is that these sites are in Korean language. I can find no English
equivalent site. You can have google do a translation for you but the
provided info isn't substantial. To download the required files you will
need the untranslated site. The required files are written in orange
text near the bottom of the page.

Once you have the required firmware, rename the file from *.exe to
*.zip. Then the "Archive Manager" in Ubuntu can extract the required
components (Note: this is a useful tip for anyone who wants to look
inside an MSwindows self-extractable zip file). Now you will have two
files "200702081154530571_TS-L632D_SC03.BIN" & "sfdnwin.exe". The *.BIN
is the firmware and sfdnwin.exe is the Samsung optical drive firmware
flash program. In Ubuntu copy them  to your MSWindows partition.
"sfdnwin.exe" doesn't run under wine as far as I can tell. You need to
run it under MSwindows from a terminal window with the following command
line "sfdnwin.exe -nocheck". "nocheck" lets you do a cross-flash. Just
load the *.BIN file then do the flash. It's quick - about 20-30secs.
Restart PC and boot up in Ubuntu and optical drive problem is solved.

Note that this firmware upgrade solves more than the problem discussed in this 
bug discussion. Other problems which I had assumed were Ubuntu or VLC bugs were 
also solved. These are as follows:
1/ Under firmware AS05 when viewing a DVD movie, if pause was used, VLC would 
produce jumpy output (ie. stop-start) after movie was restarted. Only solution 
was to restart PC. Restart of VLC didn't fix problem. After firmware upgrade to 
SC03 problem has gone.
2/ Under firmware AS05 when viewing a movie with VLC and using slider bar at 
bottom to navigate around the movie, VLC would often lockup. After upgrade to 
SC03 VLC works fine with slider bar navigation.

Solution for persons without MSwindows bootable partition:

I haven't tried this but it is reported to work for a type of System76 laptop.
See entry by Thomas Aaron (on 2007-08-13) in Bug #117441 .
Note that this is the same bug as reported here but this bug number is specific 
to System76 laptops. Thomas has come up with a neat solution for the Darter 
using two USB memory sticks. Perhaps the same (or similar) solution will work 
on any PC. If not, perhaps some smart Ubuntu/Linux person could come up with a 
similar generic solution?

Note that this solution uses the DOS version of Samsung's optical drive
firmware flash program called "sfdndos.exe". Bug #117441 provides the
required files as attachments.

Some important notes:
There is reference around the web to an AS99 firmware. I have only read bad 
reports about this. The version I saw was dated 2006 & the "sfdnwin.exe" was 
dated 2004. Some MSWindows users have reported that it erased their HD 
partitions others report no improvement to drive operation. I have found no 
official ASUS reference to this firmware version for my laptop and it appears 
to be only available from third party sites. My recommendation is STAY AWAY 
from this firmware unless you have some info that I don't. Goto SAMSUNG or your 
laptop company for your firmware & firmware flash program.

In Summary:
1/This cross-flash upgrade to SC03 works for the TS-L632D on the Asus A6Rp and 
COMPLETELY SOLVES this bug plus other problems. It probably would work for any 
TS-L632D. The SC03 and/or SC04 firmware for the TS-L632D also appears to work 
for some other Samsung drive models.

2/If you don't have a bootable MSwindows partition see Bug #117441 for a

3/This bug is clearly not an Ubuntu bug nor a Linux kernel bug. It is a
bug in the optical drive firmware from Samsung.

4/ Asus & Samsung would probably not recommend cross-flashing. However,
as far as I can tell, there is no other choice if you want your optical
drive to function correctly.


Feisty freeze, kernel (?) tries to access DVD drive
You received this bug notification because you are a member of Ubuntu
Bugs, which is the bug contact for Ubuntu.

ubuntu-bugs mailing list

Reply via email to