Printing finally works, but it was a lengthy and complicated process. Here are 
the steps I took, as best as I can remember:
(1) installed 16.04 on a different machine (virgin install) - so that I can 
find out what the real picture is
(2) ran gnome-software (because on the distro update this gnome-software 
command is not part of my gui menu, only the previous "Ubuntu Software Center" 
is there.
(3) downloaded recommended 16.04 missing software, including cups (in fact, I 
removed cups related software with synaptic package manager when printing did 
not work)
(4) Studied 16.04 wiki printing related stuff. Discovered that 
/etc/cups/cupsd.conf file did not exist on my machine, but there was a 
cupsd.conf.O file still there.
(5) Edited the cupsd.conf.O file according to wiki instructions and saved it 
without the .O tail; restarted cups service according to wiki.
(6) Now the cups web interface ( worked, and the printer setting 
gui also worked.
(7) The rest of the stuff was the same as when I installed printers years back 
with the first installation of xubuntu, then 12.04. Because I have an HP 
Laserjet P1102w printer I had to run hp-plugin -i command from terminal in 
order to avoid gui printer setup error.
(8) I could also install my Lexmark color printer using samba network shared 
printer from my old Fc3 machine and selecting Generic Postscript driver. Same 
trick I did before because the Lexmark proprietary driver package installation 
did not work from Xubuntu. This was a workaround. My old Fc-3 linux machine 
shares the same Lexmark color printer to not only xubuntu bu also to old 
Windows machines as well.
F.Y.I. - hope this helps developers and others with similar problems

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  printing not working after upgrade to 16.04

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to